velocity-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From henn...@apache.org
Subject svn commit: r491222 - in /velocity/site: README.txt site/pom.xml site/src/site/apt/site-building.apt
Date Sat, 30 Dec 2006 14:01:48 GMT
Author: henning
Date: Sat Dec 30 06:01:46 2006
New Revision: 491222

URL: http://svn.apache.org/viewvc?view=rev&rev=491222
Log:
Site builds fine with maven 2.0.5-SNAPSHOT. Add some notices
here. Please lobby on the maven-dev lists for a quick release of maven
2.0.5 ;-)




Modified:
    velocity/site/README.txt
    velocity/site/site/pom.xml
    velocity/site/site/src/site/apt/site-building.apt

Modified: velocity/site/README.txt
URL: http://svn.apache.org/viewvc/velocity/site/README.txt?view=diff&rev=491222&r1=491221&r2=491222
==============================================================================
--- velocity/site/README.txt (original)
+++ velocity/site/README.txt Sat Dec 30 06:01:46 2006
@@ -23,8 +23,14 @@
 Building the Site
 -----------------
 
- Apache Velocity uses Apache Maven 2 to build the site. It has been
- tested with Maven 2.0.4 and should work with all versions beyond.
+ Apache Velocity uses Apache Maven 2 to build the site.
+
+ Due to a problem in the Maven 2.0.x core, the site needs to be
+ built with a version of at least Maven 2.0.5 or the development
+ snapshot 2.0.5-SNAPSHOT.
+
+ If you want to stick to the released 2.0.4 version, there is a
+ workaround described below.
 
  The site consists of multiple modules: The Site itself and some
  helpers that must be installed in your local Maven repository. These
@@ -59,6 +65,33 @@
 Create the Apache Velocity Site
 -------------------------------
 
+ *BEGIN WORKAROUND for Maven 2.0.4*
+
+ To resolve all dependencies for the site building, add the following
+ block to the <extensions> section of the site POM.
+
+ <extensions>
+ ...
+   <extension>
+     <groupId>org.apache.maven.plugins</groupId>
+     <artifactId>maven-site-plugin</artifactId>
+     <version>2.0-SNAPSHOT</version>
+   </extension>
+ </extensions>
+
+ Now you can build the site as described below.
+
+ However the bug inside maven prevents you from running the site
+ locally using site:run or deploying it to velocity.apache.org using
+ site:deploy. If you want to do so, you must *remove all extensions*
+ (or just comment them out) from the site POM.
+
+ Does all of that suck? Yes, it does. So please lobby for a quick
+ release of Maven 2.0.5 or go through the journey of building it
+ locally from scratch. Even better, ask another person to do it. ;-).
+
+ *END WORKAROUND for Maven 2.0.4*
+
  To build the site, enter the "site" directory and run "mvn" (the
  default goal here is "site-post" which generates the site and also
  installs a few extra files (e.g. the download.cgi script for
@@ -122,6 +155,17 @@
  Both messages mean that you neglected to install the helper
  modules. Please go to the directory where you found this README and
  run "mvn". Afterwards the site should build fine.
+
+ An error message like this:
+
+ [ERROR] BUILD ERROR
+ [INFO] ------------------------------------------------------------------------
+ [INFO] Internal error in the plugin manager executing goal 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:run':
Unable to find the mojo 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:run' in the
plugin 'org.apache.maven.plugins:maven-site-plugin'
+
+ means that you are probably using Apache Maven 2.0.4 and either forgot
+ to add the workaround described above when trying to build the site or
+ forgot to remove the extensions as described above when trying to execute
+ site:run or site:deploy.
 
 
 Questions and contact

Modified: velocity/site/site/pom.xml
URL: http://svn.apache.org/viewvc/velocity/site/site/pom.xml?view=diff&rev=491222&r1=491221&r2=491222
==============================================================================
--- velocity/site/site/pom.xml (original)
+++ velocity/site/site/pom.xml Sat Dec 30 06:01:46 2006
@@ -222,11 +222,6 @@
         <groupId>org.apache.velocity</groupId>
         <version>0.0.1</version>
       </extension>
-      <extension>
-        <groupId>org.apache.maven.plugins</groupId>
-        <artifactId>maven-site-plugin</artifactId>
-        <version>2.0-SNAPSHOT</version>
-      </extension>
     </extensions>
   </build>
 </project>

Modified: velocity/site/site/src/site/apt/site-building.apt
URL: http://svn.apache.org/viewvc/velocity/site/site/src/site/apt/site-building.apt?view=diff&rev=491222&r1=491221&r2=491222
==============================================================================
--- velocity/site/site/src/site/apt/site-building.apt (original)
+++ velocity/site/site/src/site/apt/site-building.apt Sat Dec 30 06:01:46 2006
@@ -27,8 +27,14 @@
 * Building the Site
 
  Apache Velocity uses {{{http://maven.apache.org/}Apache Maven 2}} to
- build the site. It has been tested with Maven 2.0.4 and should work
- with all versions beyond.
+ build the site.
+
+ Due to a problem in the Maven 2.0.x core, the site needs to be
+ built with a version of at least Maven 2.0.5 or the development
+ snapshot 2.0.5-SNAPSHOT.
+
+ If you want to stick to the released 2.0.4 version, there is a
+ workaround described below.
 
  The site consists of multiple modules: The Site itself and some
  helpers that must be installed in your local Maven repository. These
@@ -59,6 +65,36 @@
 
 * Create the Apache Velocity Site
 
+** {WORKAROUND for Maven 2.0.4}
+
+ To resolve all dependencies for the site building, add the following
+ block to the <<<\<extensions\>>>> section of the site POM.
+
++--
+ <extensions>
+ ...
+   <extension>
+     <groupId>org.apache.maven.plugins</groupId>
+     <artifactId>maven-site-plugin</artifactId>
+     <version>2.0-SNAPSHOT</version>
+   </extension>
+ </extensions>
++--
+
+ Now you can build the site as described below.
+
+ However the bug inside maven prevents you from running the site
+ locally using <<<site:run>>> or deploying it to <<<velocity.apache.org>>>
using
+ <<<site:deploy>>>. If you want to do so, you must <remove all extensions>
+ (or just comment them out) from the site POM.
+
+ Does all of that suck? Yes, it does. So please lobby for a quick
+ release of Maven 2.0.5 or go through the journey of building it
+ locally from scratch. Even better, ask another person to do it. ;-).
+
+
+** Create the Apache Velocity Site using Apache Maven
+
  To build the site, enter the <site> directory and run <<<mvn>>>
(the
  default goal here is <site-post> which generates the site and also
  installs a few extra files (e.g. the <<<download.cgi>>> script for
@@ -125,6 +161,22 @@
  Velocity Site Helper modules}install the helper modules}}. Please go
  to the directory where you found this README file and run
  <<<mvn>>>. Afterwards the site should build fine.
+
+=====
+
+ An error message like this:
+
++--
+ [ERROR] BUILD ERROR
+ [INFO] ------------------------------------------------------------------------
+ [INFO] Internal error in the plugin manager executing goal 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:run':
Unable to find the mojo 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:run' in the
plugin 'org.apache.maven.plugins:maven-site-plugin'
++--
+
+ means that you are probably using Apache Maven 2.0.4 and either
+ forgot to add the {{{#WORKAROUND for Maven 2.0.4}workaround described
+ above}} when trying to build the site or forgot to remove the
+ extensions as described above when trying to execute <<<site:run>>>
+ or <<<site:deploy>>>.
 
 
 * Questions and contact



Mime
View raw message