uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikolai Krot <tal...@gmail.com>
Subject Re: Problem running UIMA Ruta ExampleProject
Date Mon, 15 Apr 2019 20:29:56 GMT
Hi Peter,

Finally, things started to work. Though I can not tell why exactly.
Retrospectively, i would guess it happened once I compiled the stuff in
ruta-2.7.0 directory and set UIMA_HOME variable. Not sure nor willing to
investigate it.

I think this page
https://uima.apache.org/d/ruta-current/tools.ruta.book.html#section.ugr.tools.ruta.workbench.install
does not mention it but I remember reading something somewhere else...

Best regards,
Nikolai



On Mon, Apr 15, 2019 at 1:54 PM Peter Klügl <peter.kluegl@averbis.com>
wrote:

> Hi,
>
>
> I tested it with Windows 10, Eclipse 4.8, Java 8.
>
>
> I'll take a closer look at it the next days.
>
>
> Best,
>
>
> Peter
>
>
> Am 13.04.2019 um 10:58 schrieb Nikolai Krot:
> > Hi Peter,
> >
> > Thanks for supporting me :) This is what I tried on Ubuntu 18.04,
> > unfortunately to no avail:
> >
> > 1) i have deleted the configuration and launched the Main.ruta script
> > directly. I have the following
> >
> > Error occurred during initialization of boot layer
> >> java.lang.LayerInstantiationException: Package
> >> jdk.internal.jimage.decompressor in both module jrt.fs and module
> java.base
> >>
> > 2) then i have edited the configuration that was created by running step
> 1,
> > changing the following
> >   Tab JRE -> set Alternate JRE to point to java-8-openjdk-amd64
> >
> > Exception in thread "main" java.lang.IllegalArgumentException: Value for
> >> descriptor is missing - Arguments: [descriptor, null, inputFolder,
> >>
> %2Fhome%2Fkrot%2Feclipse-other%2Fruta-2.7.0%2Fexample-projects%2FExampleProject%2Finput,
> >> outputFolder,
> >>
> %2Fhome%2Fkrot%2Feclipse-other%2Fruta-2.7.0%2Fexample-projects%2FExampleProject%2Foutput,
> >> mode, run, encoding, UTF-8, view, _InitialView, inputRecursive, false,
> >> addsdi, false, serialFormat, XMI]
> >>     at
> >>
> org.apache.uima.ruta.ide.launching.RutaLauncher.throwException(RutaLauncher.java:172)
> >>     at
> >>
> org.apache.uima.ruta.ide.launching.RutaLauncher.parseCmdLineArgs(RutaLauncher.java:111)
> >>     at
> >>
> org.apache.uima.ruta.ide.launching.RutaLauncher.main(RutaLauncher.java:176)
> >>
> >
> > this looks  like something very basic related to environment
> configuration,
> > but as being non-java guy, i can not solve it.
> >
> > If ExampleProject works for you, could you share your setup: OS, eclipse
> > version, JDK, etc whatever is relevant?
> >
> > Best regards,
> > Nikolai
> >
> > On Tue, Apr 9, 2019 at 3:27 PM Peter Klügl <pkluegl@gmail.com> wrote:
> >
> >> Hi,
> >>
> >>
> >> hmm, I think I have to try to reproduce it...
> >>
> >>
> >> Can you try it with Java 8? There is an option in the launch config.
> >>
> >> Can you delete the old launch config and try to launch the script
> >> directly: Open the script in the Editor and simply press the Run button
> >> without selecting anything?
> >>
> >>
> >> Best,
> >>
> >>
> >> Peter
> >>
> >>
> >> Am 09.04.2019 um 14:46 schrieb Nikolai Krot:
> >>> Hallo Peter,
> >>>
> >>> Thank you for your prompt reply.
> >>>
> >>> As recommended, I tried Photon (4.8.0), this time on Ubuntu 18.04
> >>> (openjdk-11), everything from the official repository. I applied the
> same
> >>> steps as before, except
> >>>
> >>> 5) in Eclipse, go to ExampleProject/input/Example1.txt, right click,
> >> select
> >>> [Debug As]. There is no ready configuration, so i created one. Well,
> the
> >>> only thing I did was pointing Launch script to Main.ruta.
> >>>
> >>> The error now is different, "Cannot connect to VM, socket closed".
> When I
> >>> just [Run as], the error pops up
> >>>
> >>> Error occurred during initialization of boot layer
> >>>> java.lang.LayerInstantiationException: Package
> >>>> jdk.internal.jimage.decompressor in both module jrt.fs and module
> >> java.base
> >>>  looks like something really wrong.. I know this is not related to UIMA
> >>> Ruta, but perhaps you could provide me with further advice on that?
> >>>
> >>> Best regards,
> >>> Nikolai
> >>>
> >>> On Mon, Apr 8, 2019 at 10:15 AM Peter Klügl <peter.kluegl@averbis.com>
> >>> wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>>
> >>>> there are some known issue with the latest Eclipse version. Can you
> try
> >>>> it with Eclipse Photon (4.8.0)?
> >>>>
> >>>> Is there more Stacktrace output? If yes, can you add it too?
> >>>>
> >>>>
> >>>> BEst,
> >>>>
> >>>>
> >>>> Peter
> >>>>
> >>>>
> >>>>
> >>>> Am 07.04.2019 um 15:36 schrieb Nikolai Krot:
> >>>>> Hi all,
> >>>>>
> >>>>> I am trying out UIMA Ruta and having hard times figuring out how
to
> run
> >>>>> ExampleProject. I am not a Java guy and at this point feel already
> >>>>> frustrated with abundant documentation.
> >>>>>
> >>>>> My steps so far have been to:
> >>>>>
> >>>>> 1) install Eclipse Version: 2019-03 (4.11.0) on Debian Linux
> >>>>> 2) install UIMA Ruta plugin from
> >>>>> http://www.apache.org/dist/uima/eclipse-update-site (via elipse
menu
> >>>>> [Install New Software])
> >>>>> 3) download und unpack source distribution of UIMA Ruta 2.7.0 (found
> at
> >>>>> http://uima.apache.org/downloads.cgi#Latest%20Official%20Releases)
> >>>>> 4) start eclipse and import ExampleProject from the distribution
> >>>> downloaded
> >>>>> in step 3)
> >>>>> 5) in Eclipse, go to ExampleProject/input/Example1.txt, right click,
> >>>> select
> >>>>> [Debug As], then in Debug Configurations there is already Main.ruta,
> i
> >>>>> simply choose it and click Debug button.
> >>>>>
> >>>>> As a result, I get an error Source not found. This is the stack:
> >>>>>
> >>>>> org.apache.uima.ruta.ide.launching.RutaLauncher at localhost:43931
> >>>>>>     Thread [main] (Suspended (exception
> >>>>>> AnalysisEngineProcessException))
> >>>>>>         PrimitiveAnalysisEngine_impl.innerCall(CAS) line: 336
> >>>>>>         PrimitiveAnalysisEngine_impl.processAndOutputNewCASes(CAS)
> >> line:
> >>>>>> 321
> >>>>>>
> >>>>  PrimitiveAnalysisEngine_impl(AnalysisEngineImplBase).process(CAS)
> >>>>>> line: 269
> >>>>>>         RutaLauncher.processFile(File, AnalysisEngine, CAS)
line:
> 242
> >>>>>>         RutaLauncher.main(String[]) line: 191
> >>>>>>
> >>>>> Could you please help me understand what is wrong? What am I missing?
> >>>>> Please bare with a non-Java guy if I am asking a really
> >> basic/stupid/etc
> >>>>> question.
> >>>>>
> >>>>> Thank you in advance
> >>>>> Nikolai
> >>>>>
> >>>> --
> >>>> Dr. Peter Klügl
> >>>> R&D Text Mining/Machine Learning
> >>>>
> >>>> Averbis GmbH
> >>>> Salzstr. 15
> >>>> 79098 Freiburg
> >>>> Germany
> >>>>
> >>>> Fon: +49 761 708 394 0
> >>>> Fax: +49 761 708 394 10
> >>>> Email: peter.kluegl@averbis.com
> >>>> Web: https://averbis.com
> >>>>
> >>>> Headquarters: Freiburg im Breisgau
> >>>> Register Court: Amtsgericht Freiburg im Breisgau, HRB 701080
> >>>> Managing Directors: Dr. med. Philipp Daumke, Dr. Kornél Markó
> >>>>
> >>>>
> --
> Dr. Peter Klügl
> R&D Text Mining/Machine Learning
>
> Averbis GmbH
> Salzstr. 15
> 79098 Freiburg
> Germany
>
> Fon: +49 761 708 394 0
> Fax: +49 761 708 394 10
> Email: peter.kluegl@averbis.com
> Web: https://averbis.com
>
> Headquarters: Freiburg im Breisgau
> Register Court: Amtsgericht Freiburg im Breisgau, HRB 701080
> Managing Directors: Dr. med. Philipp Daumke, Dr. Kornél Markó
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message