uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl <peter.klu...@averbis.com>
Subject Re: Ruta start issues
Date Fri, 01 Mar 2019 11:45:08 GMT
Hi Erik,


I am glad to hear that you take a look at Ruta :-)


There are still some issues with Java 11 in the latest release.


Your analysis is completely correct. The feature "timestamp" is new in
Ruta 2.7.0.


Can you check if the feature is available in the type system description
you used to create the CAS and, in the case of the Workbench, in the
type system description you used to open the CAS in the Annotation Editor?

Please mind that the Annotation Editor is able to remember the type
system description that was used previously (see preferences). And
concerning Ruta, the descriptors are not automatically updated when a
new version of the Workbench is installed.


Best,


Peter



Am 01.03.2019 um 12:37 schrieb Erik Fäßler:
> Hi all,
>
> I am trying to get started with UIMA Ruta. It really looks like an interesting and useful
project. So I installed a fresh Eclipse, downloaded the 2.7 source distribution from the UIMA
download page and imported the ExampleProject.
>
> When I try to run the Main.ruta script with JRE 11.0.2 on my Mac, I get the error message
>
> Error occurred during initialization of boot layer
> java.lang.LayerInstantiationException: Package jdk.internal.jimage.decompressor in both
module jrt.fs and module java.base
>
> So I switched to JRE 1.8.0_152. Now, the code will run but output
>
> Mar 01, 2019 12:34:07 PM org.apache.uima.jcas.impl.JCasImpl reportInitErrors(810)
> WARNING: 
> JCas Type "org.apache.uima.ruta.type.DebugBlockApply" implements getters and setters
for feature "timestamp", but the type system doesnt define that feature.
> JCas Type "org.apache.uima.ruta.type.DebugRuleApply" implements getters and setters for
feature "timestamp", but the type system doesnt define that feature.
> JCas Type "org.apache.uima.ruta.type.DebugScriptApply" implements getters and setters
for feature "timestamp", but the type system doesnt define that feature.
>
> Then, I wanted to check out the “Ruta Explain” perspective and tried to run Main.ruta
with the debugger. This won’t finish at all due to the exception
>
> org.apache.uima.cas.CASRuntimeException: Feature "timestamp" is not defined for type
"org.apache.uima.ruta.type.DebugScriptApply”.
>
> It actually seems to be straight forward what is going wrong, the compile type system
class does not match the descriptor. But this look like Ruta internals to me, I am not quite
sure if and where I went down the wrong path.
>
> Any hints?
>
> Thanks,
>
> Erik

-- 
Dr. Peter Klügl
R&D Text Mining/Machine Learning

Averbis GmbH
Tennenbacher Str. 11
79106 Freiburg
Germany

Fon: +49 761 708 394 0
Fax: +49 761 708 394 10
Email: peter.kluegl@averbis.com
Web: https://averbis.com

Headquarters: Freiburg im Breisgau
Register Court: Amtsgericht Freiburg im Breisgau, HRB 701080
Managing Directors: Dr. med. Philipp Daumke, Dr. Kornél Markó


Mime
View raw message