uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: UIMA 3 support in Ruta and DKPro
Date Tue, 02 Oct 2018 10:00:53 GMT
uimaFIT v3 is on my todo list for some time already. A few
weeks ago, I almost announced a vote for a release candidate,
but then Apache policy regarding checksums changed, mandating
a switch to SHA 256/512, so I dropped the RC again.

We are now about to release a new version of the UIMA parent
POM which will produce SHA 512 checksums for our artifacts,
then I'll go back to running the uimaFIT v2 and v3 releases.

There are no more significant changes scheduled for uimaFIT
2.5.0 and 3.0.0 - it's basically just doing the release now.

If you are brave enough to use unreleased version, you could
just check out the uimaFIT 3.0.x branch [1] temporarily and 
build the SNAPSHOTs locally.

As far as I understood, the Ruta v3 release is basically waiting
for the uimaFIT 3.0.0 release - but I don't know anything more
about if/how many changes in addition to the uimaFIT v3 release
are necessary to perform in Ruta before v3 can be released.

Cheers,

-- Richard

[1] https://github.com/apache/uima-uimafit/tree/3.0.x

> On 2. Oct 2018, at 09:49, Mario Juric <mj@unsilo.ai> wrote:
> 
> Hi Peter & Richard,
> 
> We are working on migrating to UIMA 3, but we are getting an awful many runtime incompatibility
complaints from DKPro and Ruta components in the form of
> 
> "JCas Class X, loaded from Y.jar, is missing required constructor; likely cause is wrong
version (UIMA version 3 or later JCas required)."
> 
> It kinda puts migration on hold for us unless there is a workaround. Do you have any
roadmap for migrating to UIMA 3?
> 
> Cheers,
> Mario


Mime
View raw message