uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <cwik...@apache.org>
Subject Re: TypePriorities configured in the descriptor of an aggregate engine are not added in uima-as
Date Mon, 14 Aug 2017 19:40:41 GMT
Please confirm that this is happening:

1) You deploy an aggregate and specify TypePriorities in aggregate analysis
engine descriptor.
2) After uima-as client initilizes, you call client's
    public ProcessingResourceMetaData getMetaData();
3) You check the returned meta and the type priorities are missing

You are observing correct behavior when you declare type priorities in
a delegate analysis engine descriptor of the aggregate

Jerry

On Fri, Aug 11, 2017 at 12:12 PM, nelson rivera <nelsonrivera12@gmail.com>
wrote:

> i have configured a priorityList in the descriptor of my aggregate
> engine, with the objetive of use correctly subiterator() function in
> my client code over the result CAS.
>
> After deploy the aggregate in uima-as, in my client code that consumes
> de uima-as service aggregate to check the priorityList configured i
> use the instruccion
> uimaAsynchronousEngine.getMetaData().getTypePriorities(); and not
> appear the priority configured. This does that the use of subiterator
> not have the expected behavior in the uima-as client.
>
> If the configuration of priorityList is made in the descriptor of one
> of the delegate of the aggregate, then if the instruccion
> uimaAsynchronousEngine.getMetaData().getTypePriorities()   in client
> code shows the priorityList configured and then the  behavior is the
> expected.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message