uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nelson rivera <nelsonriver...@gmail.com>
Subject Re: TypePriorities configured in the descriptor of an aggregate engine are not added in uima-as
Date Fri, 25 Aug 2017 12:25:23 GMT
Thanks for your attention Jerry, i wait the solution to integrate it
in production

2017-08-24 14:27 GMT-04:00, Jaroslaw Cwiklik <cwiklik@apache.org>:
> Nelson, I was able to recreate this problem and am working on a fix now.
> Jerry
>
> On Wed, Aug 16, 2017 at 3:39 PM, nelson rivera <nelsonrivera12@gmail.com>
> wrote:
>
>> Jerry, i understand and wait. Thanks for your attention.
>>
>> 2017-08-16 15:09 GMT-04:00, Jaroslaw Cwiklik <cwiklik@apache.org>:
>> > Nelson, I need more time to look into this. Quite busy at a moment.
>> Unless
>> > someone else wants to jump in here I will address the problem when I am
>> > done with current work load,
>> >
>> > Jerry
>> >
>> > On Mon, Aug 14, 2017 at 4:36 PM, Jaroslaw Cwiklik <cwiklik@apache.org>
>> > wrote:
>> >
>> >> Thanks, I will try to test this scenario and get back to ya.
>> >>
>> >> Jerry
>> >>
>> >> On Mon, Aug 14, 2017 at 4:27 PM, nelson rivera <
>> nelsonrivera12@gmail.com>
>> >> wrote:
>> >>
>> >>> Yes, that is happening
>> >>>
>> >>> 2017-08-14 15:40 GMT-04:00, Jaroslaw Cwiklik <cwiklik@apache.org>:
>> >>> > Please confirm that this is happening:
>> >>> >
>> >>> > 1) You deploy an aggregate and specify TypePriorities in aggregate
>> >>> analysis
>> >>> > engine descriptor.
>> >>> > 2) After uima-as client initilizes, you call client's
>> >>> >     public ProcessingResourceMetaData getMetaData();
>> >>> > 3) You check the returned meta and the type priorities are missing
>> >>> >
>> >>> > You are observing correct behavior when you declare type priorities
>> in
>> >>> > a delegate analysis engine descriptor of the aggregate
>> >>> >
>> >>> > Jerry
>> >>> >
>> >>> > On Fri, Aug 11, 2017 at 12:12 PM, nelson rivera <
>> >>> nelsonrivera12@gmail.com>
>> >>> > wrote:
>> >>> >
>> >>> >> i have configured a priorityList in the descriptor of my aggregate
>> >>> >> engine, with the objetive of use correctly subiterator() function
>> >>> >> in
>> >>> >> my client code over the result CAS.
>> >>> >>
>> >>> >> After deploy the aggregate in uima-as, in my client code that
>> >>> >> consumes
>> >>> >> de uima-as service aggregate to check the priorityList configured
>> >>> >> i
>> >>> >> use the instruccion
>> >>> >> uimaAsynchronousEngine.getMetaData().getTypePriorities(); and
not
>> >>> >> appear the priority configured. This does that the use of
>> subiterator
>> >>> >> not have the expected behavior in the uima-as client.
>> >>> >>
>> >>> >> If the configuration of priorityList is made in the descriptor
of
>> one
>> >>> >> of the delegate of the aggregate, then if the instruccion
>> >>> >> uimaAsynchronousEngine.getMetaData().getTypePriorities()  
in
>> client
>> >>> >> code shows the priorityList configured and then the  behavior
is
>> >>> >> the
>> >>> >> expected.
>> >>> >>
>> >>> >
>> >>>
>> >>
>> >>
>> >
>>
>

Mime
View raw message