uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Kl├╝gl <peter.klu...@averbis.com>
Subject Re: UIMA Ruta use of features in a block statement
Date Fri, 14 Jul 2017 14:50:54 GMT
Hi


Am 13.07.2017 um 10:31 schrieb Sumit Madan:
> I'll take a look. Could take a few days until I get back to you.
>
> No hurry as it is not urgent.
>

It's hard to reproduce the problem using the xmis since I do not have
the typesystems. I do not see any problems in the Applied Rules view.
Maybe you can debug it? I would set a (conditioned) break point at
RutaRuleElement line 59 (current trunk) and investigate why an empty
list is returned for the Lemma rule in the block.

Is there any change of the filtering settings, action or parameter? Have
you tried to update to the current release candidate for testing? Have
you set any special parameters for internal indexing?


Best,

Peter

>>
>>> Another small issue: DebugRuleApply.element doesn't always match with
>>> the original rules. For example, for the second rule, it contains the
>>> value "Lemma{-&gt;MATCHEDTEXT(s, ),ASSIGN(a, contains(s))};", which is
>>> not identical to the user input.
>>>
>> Yes, unfortunately I did not really take care of it since it is only
>> debug info. I assume you are referring to the comma? I'll fix that. Let
>> me know if you observe more.
>
> Yes, the comma, and also the contains() method is missing the second
> string parameter.
>
> I've one more issue: The loading of extensions is not working if I run
> Ruta under Groovy (2.4.7) (and with Java 1.7 or 1.8 source and target
> compatibility). But I haven't looked deep into it. I'll provide you
> more information as soon as I have it. (The runnable test I created
> was first developed with Groovy.)
>
>> Best,
>>
>> Peter
>


Mime
View raw message