uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell Bateman <r...@windofkeltia.com>
Subject Build error for UIMA because of Eclipse?
Date Mon, 23 Jan 2017 20:25:42 GMT

I don't develop this software, only build and use it. Recently, this 
began to happen. Can anyone enlighten me?

 From my build:

[INFO] 
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Apache UIMA Java SDK: uimaj-parent ................. SUCCESS [  
0.981 s]
[INFO] Apache UIMA Base: uimaj-test-util: JUnit utilities . SUCCESS [  
0.766 s]
[INFO] UIMA Base: uimaj-core .............................. SUCCESS [  
1.671 s]
[INFO] Apache UIMA Base: jVinci: Vinci Transport Library .. SUCCESS [  
0.202 s]
[INFO] Apache UIMA Base: uimaj-adapter-vinci: Vinci Adapter SUCCESS [  
0.326 s]
[INFO] Apache UIMA Base: uimaj-cpe: Collection Processing Engine SUCCESS 
[  0.498 s]
[INFO] Apache UIMA Base: uimaj-document-annotation ........ SUCCESS [  
0.145 s]
[INFO] Apache UIMA Base: uimaj-tools: Tools ............... SUCCESS [  
0.669 s]
[INFO] Apache UIMA Base: uimaj-examples: SDK Examples ..... SUCCESS [  
0.468 s]
[INFO] Apache UIMA Base: uimaj-adapter-soap: SOAP Adapter . SUCCESS [  
0.229 s]
[INFO] Apache UIMA Base: uimaj-component-test-util: for JUnit SUCCESS [  
0.151 s]
*[INFO] Apache UIMA Eclipse: uimaj-ep-debug ................ FAILURE [  
1.136 s]*
[INFO] Apache UIMA Eclipse: uimaj-ep-jcasgen .............. SKIPPED
.
.
.
[INFO] 
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 7.926 s
[INFO] Finished at: 2017-01-23T13:14:58-07:00
[INFO] Final Memory: 39M/946M
[INFO] 
------------------------------------------------------------------------
*[ERROR] Failed to execute goal on project uimaj-ep-debug: Could not 
resolve dependencies for project 
org.apache.uima:uimaj-ep-debug:jar:2.4.0: Failed to collect dependencies 
at org.eclipse.jdt:org.eclipse.jdt.debug.ui:jar:3.2.0 -> 
org.eclipse.jdt:org.eclipse.jdt.ui:jar:3.12.2 -> 
org.eclipse.platform:org.eclipse.search:jar:3.11.1 -> 
org.eclipse.platform:org.eclipse.ui:jar:3.108.1 -> 
org.eclipse.platform:org.eclipse.swt:jar:3.105.2 -> 
org.eclipse.platform:org.eclipse.swt.gtk.linux.aarch64:jar:[3.105.2,3.105.2]: 
No versions available for 
org.eclipse.platform:org.eclipse.swt.gtk.linux.aarch64:jar:[3.105.2,3.105.2] 
within specified range -> [Help 1]*



*~/.m2/repository/org/eclipse/platform/org.eclipse.swt.gtk.linux.aarch64 
$ ll*
total 12
drwxr-xr-x.  2 russ russ 4096 Jan 23 12:55 .
drwxr-xr-x. 87 russ russ 4096 Jan 23 12:46 ..
-rw-r--r--.  1 russ russ  509 Jan 23 12:55 resolver-status.properties




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message