uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: XmiCasSerializer omits namespace prefixes in XML elements
Date Wed, 23 Nov 2016 21:47:01 GMT
see for instance, https://issues.apache.org/jira/browse/UIMA-5177


On 11/23/2016 2:09 PM, Burn Lewis wrote:
> I've seen JUnit tests failing in this way when Saxon9 is in the classpath.
> Saxon and UIMA don't appear to work together.
>
> ~Burn
>
> On Wed, Nov 23, 2016 at 1:24 PM, Oliver Ferschke <oliver.ferschke@mmodal.com
>> wrote:
>> Hi all,
>> I'm experiencing some odd behavior of the XmiCasSerializer (UIMA 2.9.0).
>> When I pass a CAS to the static "serialize(CAS aCAS, java.io.OutputStream
>> aStream)" method within our runtime environment, it produces an XMI with
>> XML-Elements without namespace prefixes,
>> e.g.
>> <SectionAnnotation id="124" sofa="17" begin="0" end="200" hidden="false"
>> ......
>> instead of
>> <cda:SectionAnnotation xmi:id="124" sofa="17" begin="0" end="200"
>> hidden="false"
>>
>> This also happens if I use the non-static methods.
>> In a minimal example that doesn't use our pipeline deployment environment,
>> this does not happen.
>> It seems like there is something in the classpath that changes the
>> behavior of the serializer but I haven't been able to pinpoint what this
>> could be.
>>
>> Has anyone ever experienced a behavior like this or knows what else I
>> could look into?
>>
>> Thanks a lot.
>> Oliver
>>
>>


Mime
View raw message