uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hendrik Lücke-Tieke <h...@outlook.com>
Subject AW: uimafit builds broken?
Date Mon, 15 Feb 2016 06:43:40 GMT
Welcome to the wonderful world of build systems...

First, I used git to check out the code from github. But neither that nor
checking out using git svn (the original source) worked correctly, because
-- due to a git feature -- the newlines in
uimafit-core/src/test/resources/data/docs/ unix-newlines.txt.bin were
replaced during checkout. (More details in "lesson 1" )

So, would you accept a pull request, which adds a .gitattributes to the
repository, so cloning the source from github will work for people using
windows?

Then I checked out using svn (had to install it for this) Now uimafit-core
builds correctly. But uimafit-maven-plugin breaks because I have maven 3.3.3
installed. 

So what version of maven would be ok, Richard? And would it be ok, if I
create a pull request which adds a maven wrapper to get rid of the
dependence of a local maven installation (which may be too bleeding edge)?

Best,
Hendrik



My Setup:
$ git svn info
URL: https://svn.apache.org/repos/asf/uima/uimafit/trunk
Last Changed Rev: 1721636
Last Changed Date: 2015-12-24 16:27:15 +0100 (Do, 24 Dez 2015)

Windows 8.1 german, 64 bit
Apache Maven 3.3.3 (7994120775791599e205a5524ec3e0dfe41d4a06;
2015-04-22T13:57:37+02:00)
Java version: 1.8.0_51, vendor: Oracle Corporation




Lesson 1: Don’t check out using git, because
uimafit-core/src/test/resources/data/docs/ unix-newlines.txt.bin will have
newlines exchanged when using git.
=====

Failing tests are:
- org.apache.uima.fit.factory.JCasBuilderTest.test(JCasBuilderTest.java:71)
-
org.apache.uima.fit.testing.factory.TokenBuilderTest.testNewlinesFromFile(To
kenBuilderTest.java:204)
- CasDumpWriterTest.test:57
- JCasBuilderTest.test:71 


Lesson 2:  Don’t use maven 3.3.3, because they have removed the mvn.bat...
===
[INFO] --- maven-invoker-plugin:1.8:run (integration-test) @
uimafit-maven-plugin ---
[INFO] Building: default\pom.xml
[INFO] ..FAILED (0.0 s)
[INFO]   Maven invocation failed. Error configuring command-line. Reason:
Maven executable not found at:
C:\Users\hatieke\bin\apache-maven-3.3.3\bin\mvn.bat






> -----Ursprüngliche Nachricht-----
> Von: Richard Eckart de Castilho [mailto:rec@apache.org]
> Gesendet: Sonntag, 14. Februar 2016 11:50
> An: user@uima.apache.org
> Betreff: Re: uimafit builds broken?
> 
> So I just did a build locally and it worked good including the
uimafit-maven-
> plugin module.
> 
> What is failing for you exactly?
> 
> What operating system/system language/Java version are you using?
> 
> How are you building?
> 
> Cheers,
> 
> -- Richard
> 
> > On 14.02.2016, at 01:50, Hendrik Lücke-Tieke <helt@outlook.com> wrote:
> >
> > Whoops - last mail went out in a hurry. I assume the main problem is
> > that uimafit-maven-plugin wont build...
> >
> > Best,
> > Helt


Mime
View raw message