uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl <peter.klu...@averbis.com>
Subject Re: Ruta, uimafit & configure
Date Thu, 01 Oct 2015 08:03:07 GMT
Hi,

yes, it is possible to configure uimaFIT analysis engines from inside a
ruta script (I actually do this quite often these days).

The problem here is that the uimaFIT analysis engine is already
initialized when the ruta analysis engine initializes its main script,
normally during initialize(). This means long before CONFIGURE is maybe
called. The configuration parameter is manditory, so that the initialize
already fails.

I discussed the same problem once with Richard, but forgot to include a
solution on the ruta side.

I do not see a clean solution for the current ruta releases, but I will
open an jira issue for it and improve it in the next releases. Rigth
now, you could either change the parameter to be optional or to specify
a default value (most likely not an option) or you could import and exec
a generated descriptor in which the parameter is set to some default value.

Best,

Peter


Am 01.10.2015 um 09:13 schrieb Josep María Formentí Serra:
> Hi all,
>
>   I'm trying to use UIMAFIT inside a Ruta script passing some parameters
> but i get an error, here an example:
>
> UIMAFIT de.tudarmstadt.ukp.dkpro.core.io.xmi.XmiWriter;
>
> Document{CONTAINS(Entity)-> CONFIGURE(XmiWriter, "targetLocation" =
> "src/test/resources"), EXEC(XmiWriter)};
>
>   And here the error:
>
> Caused by: org.apache.uima.resource.ResourceConfigurationException: No
> value has been assigned to the mandatory configuration parameter
> targetLocation.
>
>   It is possible pass parameters to an uimaFit engine?
>
> Thanks in advance,
>   JM
>


Mime
View raw message