uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Eisenberg <jeise...@fiu.edu>
Subject Getting UIMA working with Eclipse-- Cannot find main for Document Analyzer
Date Mon, 17 Aug 2015 14:32:58 GMT
I am trying to set up UIMA for Java with Eclipse.

I downloaded the UIMA binary zip from Apache, unzipped it, put it in a
directory that I configured as
the UIMA_HOME environment variable in my bash profile and in eclipse. I
also set my paths as the
UIMA readme instructs. I ran adjustExamplePaths.sh from the terminal with
no errors. I am able to run
the document analyzer through the terminal with no errors; I am able to see
the example annotations.

In eclipse I downloaded the EMF plugin and both UIMA plugins. Then to test
if everything works in
Eclipse, I imported (from existing projects) the examples folder in
UIMA_HOME. I run it, select
document analyzer from the list and I get the following error:

Error: could not find or load main class
org.apach.uima.tools.docanalyzer.DocumentAnalyzer

Since tehn I've added the uima-tools.jar to the class path for doc analyzer
and I am still getting the
same error.

Any advice would help.

Thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message