uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mandy Neumann <mandy.neum...@gesis.org>
Subject Re: Problem with Eclipse and UIMA
Date Wed, 22 Jul 2015 08:13:58 GMT
Lothar Diefenbaker <jamhowolvie@...> writes:
> 
> Hello Marshall,
> 
> Thank you very much for your help and answer, sorry I didn't answer before.
> Your assupmtions were correct, I downloaded the binary package and I try to
> import the uimaj-examples into Eclipse, the problem was exactly the same as
> Molly's.
> 
> I tried to run them from eclipse, if I run the jars from the command line
> they work fine. I did ran the script to adjust the paths, and both the
> JAVA_HOME and the UIMA_HOME are set as environment variables. I had already
> tried add the uima-tools jar file as a external jar, yet with no results,
> I'll try that again.
> 
> Anyway what finally worked for me was to download the UIMA source
> distibution and build it. I tried building it with maven from command line;
> I also imported it as a maven project to build it on Eclipse and they both
> seemed to work. I'm now able to run the tools and examples from eclipse.
> 
> Again I thank you very much for your help and interest ;)
> Lothar

Hello Lothar,

I have the exact same issues as you had when you asked here. I'm not able to
run any of the launch configurations of UIMA in eclipse...

Obviously you found a workaround, but I don't quite understand what you did,
because I'm not very familiar with maven. Could you please explain in detail
what you did to "build the UIMA source distribution"? Did you import the
whole source into eclipse (that would be a lot of projects)?

Best,
Mandy



Mime
View raw message