uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Armin.Weg...@bka.bund.de>
Subject AW: DKPro NamedEntity ClassCastException
Date Thu, 30 Jul 2015 13:09:40 GMT
Hi Richard!

No, I don't use initialize() without args directly. I use initialize(UimaContext context)
and call super.initialize(context).

Best,
Armin

-----Urspr√ľngliche Nachricht-----
Von: Richard Eckart de Castilho [mailto:rec@apache.org] 
Gesendet: Donnerstag, 30. Juli 2015 14:46
An: user@uima.apache.org
Betreff: Re: DKPro NamedEntity ClassCastException

On 30.07.2015, at 13:23, Armin.Wegner@bka.bund.de wrote:

> Hello Richard and Peter!
> 
> The problem is solved but not really understood. 
> 
> a) Downgrading form uimaFIT 2.1.0 to uimaFIT 2.0.0 helped. So, it must be connected to
2.1.0 in some way.
> 
> b) Adding an annotator with cas.getJCas() or jcas.getCas().getJCas() in process() to
the begin of the pipeline does nothing. 
> 
> c) Adding cas.getJCas() or jcas.getCas().getJCas() to the collection reader does nothing.

> 
> d) Changing the collection reader from CasCollectionReader_ImplBase to JCasCollectionReader_ImplBase
solved it. I don't use JCas often. I prefer the more flexible CAS.

Uhm - JCasCollectionReader_ImplBase does directly inherit from the UIMA CollectionReader_ImplBase
- nothing special.

Did you possibly override the initialize() method (the one with no args) without calling super?

... although don't wouldn't see why that would make a difference either.

Cheers,

-- Richard

Mime
View raw message