uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Wunderlich <martin...@gmx.net>
Subject NPE when trying to get casProcessors from CPE description
Date Sat, 11 Jul 2015 08:18:30 GMT
Hi  all, 

I am  trying to run a pair-wise classification experiment using the DKPro TC framework. The
execution fails during the meta-info stage due to a NullPointerException that originates in
the CpeBuilder class from UIMAfit v.2.1.0 (hence the post to this list and not the DKpro list).
I had a closer look at the code and the NPE is triggered at the following line in the CpeBuilder:


cpeDesc.getCpeCasProcessors().setPoolSize(maxProcessingUnitThreadCount + 2);

The underlying root cause is that the casProcessors object returned by the call to cpeDesc
is Null, but I don’t understand why. The cpeDesc lists a number of fields as having Null
values: 

org.apache.uima.collection.impl.metadata.cpe.CpeDescriptionImpl: 
casInitializer = NULL
configParameterSettings = NULL
configurationParameterSettings = NULL
import = NULL
sofaNameMappings = NULL
configurationParameterSettings = NULL
cpeCasProcessors = NULL
outputQueue = NULL
startAt = NULL
startingEntityId = NULL


Unfortunately, I am not too familiar with the inner workings of the UIMA(fit) framework so
I am not sure how, why and where these fields were set to Null. 
Could someone perhaps point me in the right direction where I should dig deeper to identify
the cause for this problem? 

Thanks a lot. 

Cheers, 

Martin
 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message