uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Klügl <peter.klu...@averbis.com>
Subject Re: Marking cosnecutive tokens with RUTA
Date Thu, 25 Jun 2015 16:03:55 GMT
Some first observations...

You should:
- remove all paths configs in your pom for the ruta-maven-plugin:
scriptPaths, descriptorPaths, resourcePaths
- remove the TypeSystem.xml file in the script folder
- remove build-helper-maven-plugin

Now the generated descriptors should be correctly configured. However,
they are not part of the jar, but only of the sources jar. There is
something special about your maven build process which I haven't found
yet...

Best,

Peter

Am 23.06.2015 um 19:41 schrieb Diego Buoro:
> Hello Peter,
>
> We would like to know how to configurate the line with the "import
> location" below, of MainTypeSystem.xml(which is genarated by the Ruta
> plugin by Maven), since in our present state, it is referecing to a file in
> two layers above of the desired. We searched in pom.xml,but we had no
> success.
>
> <typeSystemDescription xmlns="http://uima.apache.org/resourceSpecifier">
>     <name>MainTypeSystem</name>
>     <imports>
>        * <import location="../../../../../../descriptor/TypeSystem.xml"/>*
>     </imports>
> ...
>
> No problem Peter, take your time.Thanks to you, we did a good progress :)
>
> All Best,
>
> Diego
>
> 2015-06-22 10:28 GMT-03:00 Peter Klügl <peter.kluegl@averbis.com>:
>
>> Hi,
>>
>> I haven't checked all files in your project, but (without looking at it
>> right now) there are several TypeSystem.xml files.
>> If they are the same files (content), then I would recommend to have
>> only one of these files, e.g., in the descriptor folder. If these files
>> are different type systems, then I would recommend to give them a
>> different name.
>>
>> You do not need to change anything if all works as expected.
>>
>> I am a bit busy right now so that I can't give a more detailed advice
>> before the end of this week.
>>
>> Best,
>>
>> Peter
>>
>> Am 19.06.2015 um 21:31 schrieb Diego Buoro:
>>> Hi again, we managed to fix our problem with the features. Our main worry
>>> at the moment is: the problems that you mentioned about having duplicated
>>> type systems all over the place are still there. Can you recommend some
>>> reference that you think would be apropriate for fixing this in our
>>> project? If not, can you be a bit clearer on what you suggest we should
>> do?
>>> All Best,
>>>
>>> Diego
>>>
>>> 2015-06-19 15:55 GMT-03:00 Diego Buoro <jklports@gmail.com>:
>>>
>>>> Hello, Peter, thanks for the suggestion as always :D
>>>>
>>>> Unfortunately, our problems weren't solved. We tried removing all paths
>>>> from the configuration and we tried setting those paths as in the
>> example
>>>> project.In both cases we were eventually able to get the program
>> running,
>>>> but we were unable to import features from ruta annotations into java.
>> We
>>>> Don't know if that happened because of some problem in the configuration
>>>> itself or in the code (which seemed to be working before these
>>>> configuration problems started). Do you have any ideas?
>>>>
>>>> All Best,
>>>>
>>>> Diego
>>>>
>>


Mime
View raw message