uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Problem with Eclipse and UIMA
Date Wed, 03 Jun 2015 13:42:00 GMT
>From the trace it looks like the classpath you're running with is missing the
main UIMA core jar. 

I assume you're launching from Eclipse.  Please check the classpath used when
launching to insure it has the UIMA core jar.

-Marshall

On 6/3/2015 2:21 AM, molly wrote:
> Hi Marshall,
>
> I have a similar issue. I followed
> http://uima.apache.org/doc-uima-annotator.html example. I added the
> uimaj-examples, too.
> When I add "uimaj-tools" as you suggedsted, I get following erroe:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/uima/internal/util/CommandLineParser
> 	at org.apache.uima.tools.cvd.CVD.createCmdLineParser(CVD.java:89)
> 	at org.apache.uima.tools.cvd.CVD.main(CVD.java:131)
> Caused by: java.lang.ClassNotFoundException:
> org.apache.uima.internal.util.CommandLineParser
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
> 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
> 	... 2 more
>
> Any idea what can be the issue?
>
> Thanks
>
>
>
>
>
>
>


Mime
View raw message