uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lothar Diefenbaker <jamhowol...@gmail.com>
Subject Problem with Eclipse and UIMA
Date Fri, 22 May 2015 13:36:32 GMT
Hello Everyone,

 I recently become involved in a project with Apache UIMA. As I was totally
unfamiliar with it as I was to eclipse, so I started reading the
documentation from the very beginning and I try to follow the tutorials.
But a problem came up when I tried to configure Eclipse to work with UIMA.
I installed the UIMA plugins for eclipse from
http://www.apache.org/dist/uima/eclipse-update-site, I followed all the
steps in order to set it up, I added my UIMA_HOME to the Java Build Path in
Eclipse. I imported the uimaj-examples but I cannot run them, when I tried
to run any of the tools I get the Error: Could not find or load main class
org.apache.uima.tools.AnnotationViewerMain (for example this happens when I
tried to run the Annotation Viewer). I know this seems to be a path
problem, so I checked the build path of the project and it does includes
everything in my installation of UIMA, the lib is there with the jar of the
tools. My environment variables of %UIMA_HOME%, %JAVA_HOME% exist and they
hold as value the path of UIMA and JAVA respectively. I also included the
lib directory of uima to the %CLASSPATH%, and the bin and lib directories
of the uima to the %PATH%.

 I tried to make the tutorial of “My first Annotator”, I created the
project RoomNumberAnnotator and followed the tutorial step by step. But at
the end when I tried to test it with the UIMA CAS Visual Debugger again I
only got Error: Could not find or load main class
org.apache.uima.tools.cvd.CVD since I cannot run the SDK tools from
eclipse. I ran from the CVD from the console and it worked, and I loaded
the analysis engine of RoomNumberAnnotator and it worked. Nevertheless I
still cannot make it work from eclipse.

 I looked for information about this and I didn't find much, which makes me
think it's something too basic to solve to require help. Anyway I've been
stuck with these days checking what can be wrong with my configurations of
java, eclipse, and classpaths. Please If someone could help me with some
advise or hint to solve these it would be much appreciated.

 I'm running Eclipse Luna 4.4.2 with EMF tools and Maven (m2e), JDK
1.7.0_79, UIMA 2.7, all these over Ubuntu 14.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message