uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: Injecting nested resources using UIMA fit
Date Sun, 24 May 2015 00:26:14 GMT
Ok, so for what it's worth - bindExternalResource() should also have worked
in the way that you used it and it was a bug that it didn't.

So both of these issues are sorted out now:

- https://issues.apache.org/jira/browse/UIMA-4425
- https://issues.apache.org/jira/browse/UIMA-4426

I can now run your code with "bindResourcesFirst" set to true.
In fact, resourceA must be bound to resourceB before resourceB
is bound to further things.

We're not supposed to expose users to unreleased artifacts... 
but if you know how to get the latest uimaFIT from SVN and hook it
up to your code, it wouldn't hurt if you could give the fixes
a spin in your environment.

-- Richard


On 23.05.2015, at 22:52, Richard Eckart de Castilho <rec@apache.org> wrote:

> On 23.05.2015, at 22:45, Mario Gazzo <mario.gazzo@gmail.com> wrote:
> 
>> Thank you, Richard. The reason I use bindExternalResource is because I have a light
DSL layer on top where everything get’s wired together from different aggregate modules.
This way the modules don’t need to be that tightly coupled up front but I just do the binding
generically right before the execution. The example doesn’t show this.
> 
> ... ok, I'll double check again whether bindExternalResource really cannot be used as
you did here ... after fixing the other problem.
> 
> My main local uimaFIT checkout is currently a bit of a mess.
> 
> /me fetching duster and dusting off...
> 
> -- Richard


Mime
View raw message