uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Debbie Zhang <debbie.d.zh...@gmail.com>
Subject Re: Error in running UIMA Ruta sample file
Date Thu, 09 Oct 2014 23:12:55 GMT
Hi Peter,

I got it working at home. However, I still can't get it working at work. Here is the complete
stack trace when I run debug as UIMA Ruta:

Main.ruta (1) [UIMA Ruta]    
   org.apache.uima.ruta.ide.launching.RutaLauncher at localhost:51604    
       Thread [main] (Suspended (exception FileNotFoundException))    
           owns: URLClassPath  (id=31)    
           URLClassPath$JarLoader.getJarFile(URL) line: 644    
           URLClassPath$JarLoader.access$600(URLClassPath$JarLoader, URL) line: 540    
           URLClassPath$JarLoader$1.run() line: 607    
           AccessController.doPrivileged(PrivilegedExceptionAction<T>) line: not available
[native method]    
           URLClassPath$JarLoader.ensureOpen() line: 599    
           URLClassPath$JarLoader.<init>(URL, URLStreamHandler, HashMap<String,Loader>)
line: 583    
           URLClassPath$3.run() line: 333    
           AccessController.doPrivileged(PrivilegedExceptionAction<T>) line: not available
[native method]    
           URLClassPath.getLoader(URL) line: 322    
           URLClassPath.getLoader(int) line: 299    
           URLClassPath.getResource(String, boolean) line: 168    
           URLClassPath.getResource(String) line: 221    
           ClassLoader.getBootstrapResource(String) line: 1150    
           Launcher$ExtClassLoader(ClassLoader).getResource(String) line: 999    
           Launcher$AppClassLoader(ClassLoader).getResource(String) line: 997    
           Launcher$AppClassLoader(ClassLoader).getResourceAsStream(String) line: 1192   

           SecuritySupport$4.run() line: 96    
           AccessController.doPrivileged(PrivilegedAction<T>) line: not available [native
method]    
           SecuritySupport.getResourceAsStream(ClassLoader, String) line: 89    
           FactoryFinder.findJarServiceProvider(String) line: 250    
           FactoryFinder.find(String, String) line: 223    
           SAXParserFactory.newInstance() line: 128    
           UIMAFramework_impl.parseFactoryConfig() line: 455    
           UIMAFramework_impl._initialize() line: 179    
           UIMAFramework.<clinit>() line: 1310    
           Ruta.wrapAnalysisEngine(URL, String, boolean, String) line: 97    
           RutaLauncher.main(String[]) line: 123    
   /usr/lib/jvm/jdk1.6.0_32/bin/java (Oct 10, 2014, 9:56:47 AM)    

Thank you!

Regards,

Debbie Zhang 

Sent from my iPhone

> On 9 Oct 2014, at 10:07 pm, Peter Klügl <pkluegl@uni-wuerzburg.de> wrote:
> 
> It's possible that that the execution did not work and the xmis are
> those that were already present in the project.
> 
> Can you delete the files in the output folder, and debug the ruta script
> again?
> 
> If the file do not occur again after running/debugging a ruta script,
> then there must be an exception: Either in the console (in Eclipse) or
> in the Error log view.
> 
> Well, you need a CAS with the special annotations. You can create some
> also without using the debug mode in eclipse. The Test Annotation view
> should normally not create those debug information as far as I remember.
> 
> Best,
> 
> Peter
> 
> Am 09.10.2014 12:48, schrieb Debbie Zhang:
>> Thanks Peter for your reply. I cleaned the project after I received your email. However,
I still got the error when I tried to debug.
>> 
>> Just now, I double clicked the output file Example1.txt.xmi. I got the rules displayed
on the rule views. Does it mean that I don't need to run the debug to get rules on the rule
views (The Reference document said debug need to be run)? It seems I only need to run the
Main.ruta from "Annotation Test" to get the .xmi files. 
>> 
>> Regards,
>> 
>> Debbie 
>> 
>>> -----Original Message-----
>>> From: Peter Klügl [mailto:pkluegl@uni-wuerzburg.de]
>>> Sent: Thursday, 9 October 2014 9:38 PM
>>> To: user@uima.apache.org
>>> Subject: Re: Error in running UIMA Ruta sample file
>>> 
>>> Did you clean the project after importing it? Menu->Project->Clean...
>>> 
>>> Best,
>>> 
>>> Peter
>>> 
>>> Am 09.10.2014 11:33, schrieb Debbie Zhang:
>>>> Hi,
>>>> 
>>>> I am new to UIMA Ruta. I try to learn UIMA Ruta by following the Ruta
>>>> Guide and Reference:
>>>> https://uima.apache.org/d/ruta-current/tools.ruta.book.html#ugr.tools.
>>>> ruta.o
>>>> verview.gettingstarted
>>>> 
>>>> So far, I am able to follow the guide to section 3.5. UIMA Ruta
>>>> Explain Perspective. According to the guide, I import the UIMA Ruta
>>>> example project and open the main Ruta script file 'Main.ruta'. I
>>>> right click the mouse and select “Debug As” “1 UIMA Ruta” on the
>>>> "Main.ruta" file. However, I get the following error:
>>>> 
>>>> Source not found for URLClassPath$JarLoader.getJarFile(URL) line: 644
>>>> 
>>>> For all “Applied Rules” “Failed Rules” “Matched Rules” views,
the
>>>> following message is displayed:
>>>> The instance view is currently not available
>>>> 
>>>> Could someone tell me what I did wrong so I can see Rules in those views?
>>>> 
>>>> Thank you in advance.
>>>> 
>>>> Regards,
>>>> 
>>>> Debbie Zhang
> 
> 

Mime
View raw message