uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: UIMA AS NullPointerException in CasDefinition constructor
Date Mon, 28 Jul 2014 21:02:47 GMT
This error comes from UIMA-AS client not the pipeline code. From what I can
see
the UIMA-AS received getMeta reply from the service (your pipeline). This
means
that it connected to the service and it received a reply.

The only thing that comes to my mind is to check the Map that you pass in
to the UIMA-AS
client code. Look here:

at
nl.novay.keywordSpotter.KeywordSpotterAS.initializeEngine(KeywordSpotterAS.java:576)

The above calls UIMA-AS client intialize() method with a Map containing
parameters.

Make sure that each key has correct value. Also, does your code add
custom Resource Manager to the Map? Does it specify CAS initial heap size?
Make sure that you specify cas pool size > 0 in the Map.

The UIMA-AS client fails while calling UIMA with given params.

        asynchManager.initialize(casPoolSize, "ApplicationCasPoolContext",
                performanceTuningSettings);

Jerry Cwiklik


On Mon, Jul 28, 2014 at 11:46 AM, Egbert van der Wal <ewal@pointpro.nl>
wrote:

>  Hi,
>
>
>
> I'm trying to convert an existing and functional UIMA pipeline to a UIMA
> AS pipeline.
>
>
>
> I'm getting there, I created deployment descriptors for the annotators and
> when running my application all individual annotators are launched
> correctly. The composite analysis engine also loads fine but I'm getting a
> NullPointerException when calling initialize(deployCtx) on the UimaAsEngine
> on line 66. See the attached text document for the full exception.
>
>
>
>
>
> I found a similar issue in the bug tracker which was fixed in UIMA AS 2.3:
>
>
>
> https://issues.apache.org/jira/browse/UIMA-1376
>
>
>
> But this seems to arise in mergeTypeSystem and this does not seem to be
> the case in my situation. The line number is the same however.
>
>
>
> Any clues on where I should look for the solution? Are my descriptors
> faulty? Is the Java code faulty? Or is this a bug in UIMA AS 2.4.0? How can
> I debug this issue?
>
>
>
> Thanks,
>
>
>
> Egbert
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message