uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Spico Florin <spicoflo...@gmail.com>
Subject UIMA AS 2.3.1 client not receiving response when using client.sendCAS(aCas)
Date Mon, 15 Apr 2013 09:58:59 GMT
Hello!
   I'm using UIMA AS 2.3.1. My pipeline has this structure:

1. An entry AAE
2. One remote RAAE connected to AAE
3. Two remote AE connected to RAAE

All of the above are running as windows services by using procrun (
http://commons.apache.org/proper/commons-daemon/procrun.html)

One of the AE is running a very expensive process of identifying geonames
locations. I call this LAE. At some point in time, the  service is stopped
due to a JVM failure:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  Internal Error (os_windows_x86.cpp:149), pid=1436, tid=7388
#  guarantee(result == EXCEPTION_CONTINUE_EXECUTION) failed: Unexpected
result from topLevelExceptionFilter
#
# JRE version: 6.0_30-b12
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.5-b03 mixed mode
windows-amd64 compressed oops)
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#

At the time of failure, the client has already sent 2 messages by using
the  asynchronous method client.sendCAS(aCas).
  The issues that I have is that after the failure, the client didn't
receive any response from the AAE, even though the client was set up to
receive a time out window of 10 minutes.
   If I send a message again to the pipeline(considering the LAE is down)
by using a new client ( a different application) via sendCas(aCas) method,
the AAE is responding with the timeout error.

     My question are:
1.Why AAE didn't send a timeout for the two sent messages at the time of
failure?
2.What can prevent the AAE to send back a response to the calling client?

I look forward for your answers.
 Thank you.
   Regards,
   Florin

****

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message