uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <eckar...@tk.informatik.tu-darmstadt.de>
Subject Re: Using JMX console with EC2
Date Wed, 24 Aug 2011 18:38:37 GMT
I recently had trouble connecting to a JMX server running on Linux (not EC2 though). It worked
after I specified a "java.rmi.server.hostname"

The parameters I used on the server side in the end were:

-Djava.rmi.server.hostname=192.168.0.25 -Dcom.sun.management.jmxremote=true -Dcom.sun.management.jmxremote.port=22222
-Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false

Maybe that'll fix it for you too.

-- Richard

Am 24.08.2011 um 16:49 schrieb Jörn Kottmann:

> On 8/23/11 10:48 PM, william.colen@gmail.com wrote:
>> Yes, I followed that instructions, but it didn't work. I tried searching
>> about this issue and looks like it is related to the second port you
>> mentioned and firewall. ActiveMQ has a configuration where one can set this
>> second port, but couldn't find something similar in UIMA. Anyway even after
>> configuring the rmiServerPort in ActiveMQ it worked, so maybe can be
>> something else.
> 
> I don't know what it else it could be, you can try to start jconsole locally
> on your server and redirect the display to your work station via ssh -X 
> user@server.
> Not sure if that work with EC2. This way you can test if you can connect 
> the local host
> without any firewall interfering.
> 
> Does anyone else has some advice to debug JMX issues?
> 
> Jörn

-- 
------------------------------------------------------------------- 
Richard Eckart de Castilho
Technical Lead
Ubiquitous Knowledge Processing Lab 
FB 20 Computer Science Department      
Technische Universität Darmstadt 
Hochschulstr. 10, D-64289 Darmstadt, Germany 
phone [+49] (0)6151 16-7477, fax -5455, room S2/02/B117
eckartde@tk.informatik.tu-darmstadt.de 
www.ukp.tu-darmstadt.de 
Web Research at TU Darmstadt (WeRC) www.werc.tu-darmstadt.de
------------------------------------------------------------------- 





Mime
View raw message