uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: How to deploy multiple UIMA-AS Services?
Date Fri, 29 Jul 2011 13:14:54 GMT
You may need to set a different JMX port for each service via -D setting if
you run on the same machine. I agree with Eddie. logging should work as
Eddie describes. If it doesnt, perhaps your logger.properties has been
modified. Just a guess.

JC

On Fri, Jul 29, 2011 at 9:00 AM, Eddie Epstein <eaepstein@gmail.com> wrote:

> Hi Jörn,
>
> Starting multiple services in the same folder should be fine. I do that
> all the time, and get uima.log, uima.log.1, uima.log.2, etc.
> My launches are usually separated by several seconds.
>
> Eddie
>
> On Fri, Jul 29, 2011 at 8:05 AM, Jörn Kottmann <kottmann@gmail.com> wrote:
> > Hi all,
> >
> > I changed my UIMA-AS Services a bit, and have now
> > one analysis pipeline per language.
> >
> > Up to now I only had one pipeline and deployed it with the
> > provided deploy script.
> >
> > Is it safe to use this script to run more than one UIMA-AS Service
> > concurrently?
> >
> > For example:
> > - Set UIMA_HOME variable
> > - Go to uima-as folder
> > - Type: bin/deployAsyncService.sh Deploy_GermanAE.xml
> > - Type: bin/deployAsyncService.sh Deploy_EnglishAE.xml
> >
> > I noticed that there is a problem with the log file, which only contains
> the
> > log
> > for the last started instance.
> >
> > Thanks,
> > Jörn
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message