uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Grivolla <j+...@grivolla.net>
Subject Re: Cas Editor: selecting annotation type
Date Fri, 06 May 2011 09:31:05 GMT
On 05/05/2011 09:30 PM, Jörn Kottmann wrote:
> On 5/5/11 6:09 PM, Jens Grivolla wrote:
>> On 05/05/2011 03:04 PM, Jörn Kottmann wrote:
>>> On 5/5/11 2:41 PM, Jens Grivolla wrote:
>>>> At least on my system (Eclipse Helios on Ubuntu 10.10) the Shift+Enter
>>>> shortcut does not work, and will be treated as an unmodified Enter,
>>>> i.e. no selection list appears. I haven't tried yet on other systems
>>>> because I need to install the updated plugins first.
>>>>
>>> Ok, I will investigate that. But then this was not the system where you
>>> experienced the hang issue in the 2.3.1 version?
>>
>> As you said, the freeze was due to the shortcut creation when the type
>> system is too big, and it ocurred on all machines.
>>
>> I sometimes have to press return twice to get a "quick annotation",
>> too, and on a different machine (Eclipse Helios on Windows XP) it
>> worked even less, to the point that I had to use the context menu.
>
> I opened a jira for the short cut issue and fixed it, would be nice if
> you could
> test. I believe the issue is related to a recently defined command and
> key binding in the
> plugin.xml. I also now did this for the quick type selection dialog
> short cut.
>
> Here is the jira:
> https://issues.apache.org/jira/browse/UIMA-2139

Shift+Enter now seems to work reliably. Plain Enter works when I select 
a word via double click, but has problems when I select a text span (on 
my Linux machine). Shift+Enter works in that case, and plain Enter works 
after pressing Shift+Enter or just pressing any other key, eg. Shift or 
Ctrl.

>> On that machine the "edit view" was having problems, too, and I
>> usually had to click on the feature name before being able to activate
>> the feature value field. I haven't tried Shift+Enter on that machine.
>
> Did you run the current trunk on that machine? If so would be nice if
> you can give me further details
> about the edit view issues. What type had the feature you clicked on?
> Are there exceptions in the error log?

Yes, that was running trunk with yesterday morning's fixes. 
Unfortunately, I don't have access to that machine anymore and can't 
give you any more details at this point.  We do have some other Windows 
machines though, and I will look if I find anything in the error logs 
both on Linux and Windows.

>>>> [..] Which brings me to another thing that
>>>> would be interesting for us: having preset feature values filled in
>>>> automatically. We would be using that to automatically fill in the
>>>> annotator's name on all annotations created by them.
>>>
>>> This you can easily do when you pre-process the files you pass to the
>>> annoator, or post-process when he gives them back.
>>
>> I've been thinking about that option. It would be quite easy at the
>> document level, but becomes a bit more complicated when each
>> annotation can come from a different annotator and files get passed
>> from one annotator to the next.
>
> For one project I created a small plugin which just defined a view for
> something similar.
> Its actual not difficult to access the CAS and updates to it through the
> Annotation Editor.

We're currently thinking of just post-processing the XMIs and adding the 
annotator name to all annotations (of the types of interest) that don't 
have a name set yet.  We'll look into doing something more sophisticated 
for the next round of annotations.

Thanks a lot for your help,
Jens


Mime
View raw message