uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eddie Epstein <eaepst...@gmail.com>
Subject Re: UIMA-AS consuming all the RAM
Date Fri, 25 Mar 2011 00:25:36 GMT
On Tue, Mar 15, 2011 at 3:06 AM, Arun Tewatia <arun.tewatia@orkash.com> wrote:
> Hi all,
> I am using UIMA-AS 2.3.0 release. I run an Aggregate with 5 AE's.
> My configuration is as follows.
>
> 8 Core Server with 16 Gb RAM.
> I run 4 clients and 10 Service instances deployed on the same server.
> I read 60,000 documents from the database server ( 15,000 for each client )
> process them under UIMA-AS and write back output to database server.
> CAS pool size for service instances is 7 and Clients is 10.
>
> Once the service are running and documents are initialized on client side,
> 10 Gb of ram is occupied out of 16 Gb available.
> The ram usage goes on increasing as the processing goes on till its
> completed. The ram gets filled up completely eventually and i have to
> terminate service instances.
>
> When i run the same Aggregate on UIMA pipeline, its works fine. Initially
> 10Gb of ram is occupied but ram usage keeps on increasing and decreasing
> over the processing time. The whole of the ram is never occupied.

Is this a single instance of the aggregate? If so I'm confused why a
single instance would take 10GB, the same as 10 instances of the
aggregate.


>
> Is this a normal behavior of UIMA-AS or am i missing something. I increased
> ram to 24Gb too, still same problem occurs.

Does it take much longer to run out of memory with 24GB? And when it
does, are all the service and client processes the same size as when
they started and the broker taking all of memory???

Eddie

Mime
View raw message