uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arun Tewatia <arun.tewa...@orkash.com>
Subject UIMA-AS consuming all the RAM
Date Tue, 15 Mar 2011 07:06:14 GMT
Hi all,
I am using UIMA-AS 2.3.0 release. I run an Aggregate with 5 AE's.
My configuration is as follows.

8 Core Server with 16 Gb RAM.
I run 4 clients and 10 Service instances deployed on the same server.
I read 60,000 documents from the database server ( 15,000 for each 
client ) process them under UIMA-AS and write back output to database 
server.
CAS pool size for service instances is 7 and Clients is 10.

Once the service are running and documents are initialized on client 
side, 10 Gb of ram is occupied out of 16 Gb available.
The ram usage goes on increasing as the processing goes on till its 
completed. The ram gets filled up completely eventually and i have to 
terminate service instances.

When i run the same Aggregate on UIMA pipeline, its works fine. 
Initially 10Gb of ram is occupied but ram usage keeps on increasing and 
decreasing over the processing time. The whole of the ram is never occupied.

Is this a normal behavior of UIMA-AS or am i missing something. I 
increased ram to 24Gb too, still same problem occurs.

Thanks !
Arun Tewatia

Mime
View raw message