uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Colen <william.co...@gmail.com>
Subject Re: PEAR Packaging Maven Plugin
Date Thu, 03 Dec 2009 13:34:11 GMT
Thank you!

To build the PearPackagingMavenPlugin I added a dummy scm configuration to
override any other configuration.

  <scm>
    <connection>scm:svn:http://127.0.0.1/svn/my-project</connection>
    <developerConnection>scm:svn:https://127.0.0.1/svn/my-project</developerConnection>
    <tag>HEAD</tag>
    <url>http://127.0.0.1/websvn/my-project</url>
  </scm>


With that I could execute "mvn install" and now I'm able to use the plugin.

On Wed, Dec 2, 2009 at 3:44 AM, Rogan Creswick <creswick@gmail.com> wrote:

> On Tue, Dec 1, 2009 at 9:25 PM, Marshall Schor <msa@schor.com> wrote:
> >> 1. I tried to perform a mvn install in PearPackagingMavenPlugin source
> but
> >> got the following error:
> >>
> >> java.lang.NullPointerException: The scm url cannot be null.
> >>
>
> I've experienced that one.  If I remember correctly, it's actually a
> red herring, and doesn't have anything to do with the scm url.  I'm
> guessing (based on what parts of my local uimaj pom I have commented
> out) that it's part of the Distribution Management configuration, but
> I can't say for sure.
> >>
> >> 2. After that I tried to use the compiled version, but I got another
> error:
> >> [INFO] Internal error in the plugin manager executing goal
> >> 'org.apache.uima:PearPackagingMavenPlugin:2.2.2-incubating:package':
> Unable
> >> to find the mojo
> >> 'org.apache.uima:PearPackagingMavenPlugin:2.2.2-incubating:package' in
> the
> >> plugin 'org.apache.uima:PearPackagingMavenPlugin'
> >> org/apache/uima/pear/tools/PackageCreatorException
> >>
>
> I've had this sort of thing happen because maven gets hungup somehow
> after it's tried and failed to satisfy a dependency.  (I can't say
> it's exactly the same... I'm running from memory.)  Something ends up
> stuck in ~/.m2/repository that prevents subsequent queries from
> working correctly.  Anyhow, try (manually) deleting the
> PearPackagingMavenPlugin directory tree from your ~/.m2 directory and
> try again.
>
> --Rogan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message