uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Fwd: Error specifying a relative path while using PEAR installer
Date Wed, 09 Sep 2009 14:57:29 GMT


Ahmed Abdeen Hamed wrote:
> Hello all,
> I sent the message below about three weeks ago and I am wondering if
> anyone had a chance to look into it. The EnglishSD.bin file is a model
> file that was part of the UIMA examples. I am calling it from a
> descriptor that my application is using using. However, I can't deploy
> the application unless I hard-code the path to point to an absolute
> path. This is an annoying problem that has been hunting me for over a
> year now. I would appreciate any help that ride me of it.
> Thanks!
> Ahmed
>   
Did you try using $main_root and/or $component_id$root?  You can search
the online reference docs for information about these and how to use them.

-Marshall
>
> ---------- Forwarded message ----------
> From: Ahmed Abdeen Hamed <ahmed.elmasri@gmail.com>
> Date: Mon, Aug 17, 2009 at 5:21 PM
> Subject: Error specifying a relative path while using PEAR installer
> To: uima-user@incubator.apache.org
>
>
> Hello,
> I am receiving an error while specifying a relative path in
> configurationParameterSettings as follows:
>         <configurationParameterSettings>
>             <nameValuePair>
>                 <name>ModelFile</name>
>                 <value>
>                     <string>../../../models/EnglishSD.bin</string>
>                 </value>
>             </nameValuePair>
>         </configurationParameterSettings>
>
> The error happens because the string value is read verbatim as the
> PEAR installer fails to replace it by absolute path. Is there a way to
> use a different tag such as <fileUrl> where you still can specify a
> relative path?
>
> I would appreciate any assistance.
> Best wishes,
> Ahmed
>
>
>   

Mime
View raw message