uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nassim Jammal" <nas...@gmail.com>
Subject VNS Server with private IP
Date Tue, 07 Oct 2008 09:02:26 GMT
Hi,

I just came across an issue while setting up a VINCI Service on a server
that doesn't have a public IP.

The server that host the Vinci Service is accesible through a public IP, but
doesn't actually know it. (Load Balancer)

Here is the scheme of the process.

The CPE call the VNS Host through a public IP

CPE ---------- Internet ------- Load Balancer --------> VNS Server (
192.168.0.1:9000)

For now everything is ok.

The VNS Server then send to the CPE the IP and Port of the service that the
CPE wanted to call.
> MyService is on 192.168.0.1:10000

CPE <---------- Internet ------- Load Balancer -------- VNS Server

The the CPE try to call the service via 192.168.0.1:10000 but this IP is not
reachable from internet.

I tried to get around this by setting up the variable VNS_HOST to the domain
that linked to the public IP, but it didn't worked.
The VNS Server still convert the domain into an IP.

I also tried to set the VNS_HOST to the public IP, but their is a security
feature on Load balancers that you can not call yourself with the public IP
within the private network.
So the service wasn't able to connect to the VNS Server.

So my question is, is anybody encountered that same issue ?

Is their anything that I can do to get around this ?

Thanks for your help.

Regards.
-- 
Nassim

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message