uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Kottmann <kottm...@gmail.com>
Subject Re: Using the UIMA plugins in an RCP application
Date Thu, 24 Jan 2008 15:38:53 GMT
Hello,

the problem here could be that you do not have the  
org.eclipse.platform.plugin
loaded in your RCP application.

Hope this helps,
Jörn


On Jan 24, 2008, at 4:26 PM, Chavan, Girish wrote:

> Hi All,
>
> I am writing an Eclipse RCP application and would like to use the UIMA
> component descriptor editor plugin within my RCP application to edit  
> the
> UIMA descriptor files. I added them as dependencies and the editor  
> shows
> up as an option under "Open with..." menu when I right click on an xml
> file.
>
>
>
> The problem is when I do try to open it, the editor fails to  
> initialize
> and thows an exception.
>
>
>
> Here is the root cause:
>
>
>
> Caused by: java.lang.NullPointerException
>
>            at
> org 
> .apache.uima.taeconfigurator.TAEConfiguratorPlugin.<clinit>(TAEConfig
> uratorPlugin.java:74)
>
>
>
>
>
> Here is the code around line 74 in TAEConfiguratorPlugin.java:
>
> ======================
>
>  static {
>
>    Bundle bundle = Platform.getBundle("org.eclipse.platform");
>
>    String versionString = (String) bundle.getHeaders().get(  --- this
> is line 74
>
>            org.osgi.framework.Constants.BUNDLE_VERSION);
>
>    PluginVersionIdentifier version = new
> PluginVersionIdentifier(versionString);
>
>    eclipseVersionMajor = version.getMajorComponent();
>
>    eclipseVersionMinor = version.getMinorComponent();
>
>    is30version = eclipseVersionMajor == 3 && eclipseVersionMinor == 0;
>
>  }
>
> ======================
>
>
>
> I am using UIMA 2.2.1. with Eclipse 3.3
>
>
>
> Any help is much appreciated.
>
>
>
> Thanks,
>
> Girish
>


Mime
View raw message