uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Eclipse update site URL incorrect in documentation
Date Tue, 08 Jan 2008 14:11:10 GMT
Hi James.

I'm having trouble reproducing this problem.  This is what I tried:

Working on a Windows XP machine:
1) downloaded the current Eclipse version (3.3.1.1)
2) started it up, went to menu Help -> SoftwareUpdates -> Find and Install
    - added the uima site as a remote
    - selected that site, plus the "EMF" site (EMF is a pre-req for UIMA)
    - hit next and waited for the next selection screen.

3) picked uima, expanded the EMF twistie, and pushed "add required 
plugins" (not sure of the name, typing from memory...)

It all downloaded / installed without errors, and seems to have worked.

Can you provide details on steps that might reproduce the problem?

Thanks. -Marshall

James Montgomery wrote:
> Thanks Marshall. The development team's efforts to improve the project and
> its distribution are appreciated.
>
> On 07/01/2008, Marshall Schor <msa@schor.com> wrote:
>   
>> Hi James -
>>
>> This is our first try at doing the update site, and we simultaneously
>> were the first project in the incubator to move the distribution point
>> for our project to the new Apache location for incubator distributions
>> and set up "mirroring".  I'll take a look (tomorrow) and see if I can
>> figure out what's gone wrong.
>>
>> -Marshall
>>
>> James Montgomery wrote:
>>     
>>> Hi developers et al.,
>>>
>>> I'm pleased the Eclipse plugins can now be installed using an Eclipse
>>>       
>> update
>>     
>>> site, but have two issues:
>>>
>>> 1. The site reported in the (online) documentation is wrong, it should
>>>       
>> be:
>>     
>>> http://www.apache.org/dist/incubator/uima/eclipseUpdateSite/
>>> (In the documentation the last directory is given as
>>>       
>> eclipse-update-site.)
>>     
>>> 2. When I ask Eclipse to visit the site to install new features it
>>>       
>> reports
>>     
>>> an error:
>>> Unable to access "
>>> http://www.apache.org/dist/incubator/uima/eclipseUpdateSite ". Error
>>> accessing site stream. [Invalid byte 1 of 1-byte UTF-8 sequence.]
>>> ...
>>>
>>> When I examine site.xml in a browser it *looks* OK to me. Any ideas? (I
>>> should also point out I already have the plugins installed manually, but
>>> would like to get the update feature working too, for the future.)
>>>
>>> TIA,
>>> James
>>>
>>> --------------------------------------------------
>>> Dr James Montgomery
>>> Postdoctoral Fellow
>>> Faculty of Information & Communication Technologies
>>> Swinburne University of Technology
>>> Melbourne, Australia
>>>
>>>
>>>       
>>     
>
>   


Mime
View raw message