uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart <eck...@linglit.tu-darmstadt.de>
Subject Re: Using PEARs in cpeGUI - a problem?
Date Thu, 08 Nov 2007 12:45:38 GMT
I tried with the Jules OpenNLP Sentence Splitter PEAR v1.1.1  
available from www.julielab.de.

It tries to load an additional type system from the classpath and  
doesn't find that. If I
manually patch the classpath it works however.

Do you believe it's a problem of the PEAR instead of the UIMA framework?

-- Richard

Am 08.11.2007 um 13:21 schrieb Michael Baessler:

> And in both cases you use the same PEAR I think. Because when I try  
> to add a PEAR to the CPE using the cpeGUI all works fine for me.
> I tested it with the RegularExpressionAnnotator that is available  
> in the Sandbox. If you build this component using Maven, a PEAR  
> package is generated.
>
> -- Michael
>
> Richard Eckart wrote:
>> I added a PEAR descriptor to the pipeline in cpeGUI the classpath  
>> is not set up properly for the PEAR when running the CPE.
>> If I hack the setUimaClassPath.sh to include the proper jars for  
>> the PEAR, it runs.
>>
>> If I create a CPE programatically and add a PEAR, the classpath  
>> enviroment is set up for the PEAR by UIMA. No need to do it
>> manually.
>>
>> -- Richard
>>
>> Am 08.11.2007 um 10:15 schrieb Michael Baessler:
>>
>>> It is possible to add a PEAR descriptor in the cpeGUI as analysis  
>>> engine, but it is not possible to change any configuration  
>>> parameters for this
>>> descriptor.
>>>
>>> What works fine when you do it programatically?
>>>
>>> -- Michael
>>>
>>> Richard Eckart wrote:
>>>> Hi there,
>>>>
>>>> following the helpful reply by Thilo Götz on my last enquiry on  
>>>> PEARs and automatically having UIMA manage their classpath, I  
>>>> now wonder if the same can work with CPEs build in cpeGUI.
>>>>
>>>> I tried adding a PEAR as a processing component in the UIMA 2.2  
>>>> cpeGUI but adding the descriptor will not cause any  
>>>> configuration options to appear. But if I programatically create  
>>>> a processing component descriptor from a PEAR descriptor and add  
>>>> it to a CPE it works fine.
>>>>
>>>> Is this a limitation of the cpeGUI or am I using it wrong?
>>>>
>>>> I want to build a CPE descriptor in the cpeGUI using PEARs and  
>>>> then load and run the thing in with an embedded UIMA in my own  
>>>> tool.
>>>>
>>>> Regards,
>>>>
>>>> Richard Eckart
>>>>
>>>> Technische Universität Darmstadt
>>>> Institute of Linguistics and Literary Studies
>>>> Department of English Linguistics
>>>>
>>>> Hochschulstrasse 1
>>>> 64289 Darmstadt
>>>> Germany
>>>>
>>>>
>>>>
>>>
>>
>> Richard Eckart
>>
>> Technische Universität Darmstadt
>> Institute of Linguistics and Literary Studies
>> Department of English Linguistics
>>
>> Hochschulstrasse 1
>> 64289 Darmstadt
>> Germany
>>
>>
>>
>

Richard Eckart

Technische Universität Darmstadt
Institute of Linguistics and Literary Studies
Department of English Linguistics

Hochschulstrasse 1
64289 Darmstadt
Germany




Mime
View raw message