uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Lally" <ala...@alum.rpi.edu>
Subject Re: How to use a SOAP component in a CPE ?
Date Thu, 29 Nov 2007 15:09:47 GMT
On Nov 29, 2007 8:31 AM, Baptiste GAILLARD <baptiste.gaillard@gmail.com> wrote:
> I've read the following in the UIMA documentation:
> Note
>
> The UIMA SDK also supports using unmanaged remote services via the
> web-standard SOAP communications protocol (see Section 3.6.1, "Deploying as
> SOAP Service"<http://incubator.apache.org/uima/downloads/releaseDocs/2.2.0-incubating/docs/html/tutorials_and_users_guides/tutorials_and_users_guides.html#ugr.tug.application.how_to_deploy_as_soap>.
> This approach is based on a proxy implementation, where the proxy is
> essentially running in an integrated mode. To use this approach with the
> CPM, use the Integrated mode, with the component being an Aggregate which,
> in turn, connects to a remote service.
>

I think this Note is actually incorrect (sorry).  I'm pretty sure that
you can just add your SOAP Service Descriptor directly to your CPE.
So you might want to give that a try. However, wrapping it an
aggregate like you did should also work, of course.

> But, when I try to add the Aggregate AE "
> AggregateWordsListAnnotatorSoapService.xml" with the "cpeGui.bat" tool the
> following error is displayed :
>
> org.apache.uima.collection.metadata.CpeDescriptionException: The object
> reference casProcessor=NULL is invalid. (Thread Name: AWT-EventQueue-0).
>

Is there any more information, such as a stack trace, printed to the console?

-Adam

Mime
View raw message