uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Serff <li...@serff.net>
Subject Re: Moving to Java 1.5?
Date Wed, 08 Aug 2007 12:54:36 GMT
I vote for 1.5!  We have no need for 1.4 compatibility.  I'm actually 
running it on Java SE 6...so I'm good. 

Andrew
Thilo Goetz wrote:
> Hi all,
>
> our upcoming (hopefully very soon) 2.2 release will still
> be Java 1.4 compatible.  We're currently having a discussion
> on the development list if for the next version, we should
> move to Java 1.5.  This would mean that future UIMA versions
> would no longer be able to run in Java 1.4, but would
> require 1.5 or newer.
>
> Java 1.4 is getting quite long in the tooth, and most people
> have moved.  Java 1.5 brought many changes and improvements
> which we would like to be able to exploit in UIMA.
>
> So my question is: would this cause major headaches for
> anybody around here?  Anybody still committed to Java 1.4
> for the foreseeable future?
>
> The corresponding uima-dev mail thread is here:
> http://www.mail-archive.com/uima-dev%40incubator.apache.org/msg03860.html
>
> --Thilo
>   


Mime
View raw message