uima-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sc...@apache.org
Subject svn commit: r993524 - /uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml
Date Tue, 07 Sep 2010 20:34:11 GMT
Author: schor
Date: Tue Sep  7 20:34:11 2010
New Revision: 993524

URL: http://svn.apache.org/viewvc?rev=993524&view=rev
Log:
[UIMA-1865] lock down transitive dependency versions for Eclipse artifacts in uima-as

Modified:
    uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml

Modified: uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml
URL: http://svn.apache.org/viewvc/uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml?rev=993524&r1=993523&r2=993524&view=diff
==============================================================================
--- uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml (original)
+++ uima/uima-as/trunk/uimaj-ep-deployeditor/pom.xml Tue Sep  7 20:34:11 2010
@@ -206,6 +206,77 @@
       <scope>provided</scope>
     </dependency>
 
+    <!-- These next dependencies are just to lock down the
+         transitive dependencies of the above.
+         This was done because on Sept 7 2010 somebody uploaded
+         corrupted versions of these to maven central. -->
+         
+     <dependency>
+      <groupId>org.eclipse.equinox</groupId>
+      <artifactId>org.eclipse.equinox.registry</artifactId>
+      <version>3.2.1</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.jobs</artifactId>
+      <version>3.2.0</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.contenttype</artifactId>
+      <version>3.2.0</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.equinox</groupId>
+      <artifactId>org.eclipse.equinox.preferences</artifactId>
+      <version>3.2.1</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.runtime.compatibility.auth</artifactId>
+      <version>3.2.0</version>
+      <scope>provided</scope>      
+    </dependency>  
+    <dependency>
+      <groupId>org.eclipse.osgi</groupId>
+      <artifactId>org.eclipse.osgi</artifactId>
+      <version>3.2.1</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.filesystem</artifactId>
+      <version>1.0.0</version>
+      <scope>provided</scope>
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.equinox</groupId>
+      <artifactId>org.eclipse.equinox.common</artifactId>
+      <version>3.2.0</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.ant</groupId>
+      <artifactId>org.eclipse.ant.core</artifactId>
+      <version>3.1.100</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.expressions</artifactId>
+      <version>3.2.1</version>
+      <scope>provided</scope>      
+    </dependency>
+    <dependency>
+      <groupId>org.eclipse.core</groupId>
+      <artifactId>org.eclipse.core.variables</artifactId>
+      <version>3.1.100</version>
+      <scope>provided</scope>      
+    </dependency> 
   </dependencies>
 
   <build>



Mime
View raw message