tuscany-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willis C White <whiw...@us.ibm.com>
Subject Re: Example of Dojo and Tuscany on Eclipse and WebSphere (RAD)
Date Mon, 15 Jun 2009 16:36:09 GMT
Thank you so much this is moving me in the right direction. Now I am 
getting an error that says

GET http://localhost:9081/HelloWorld/HelloWorldService?smd
http://localhost:9081/HelloWorld/HelloWorldService?smd         404 Not 
Found       3ms 


Error 404: SRVE0190E: File not found: /HelloWorldService





Willis C White III 
IQ Technology Projects
IBM CIO Technology & Innovation
Home office 845 331-5134
Cell 845 853-3827
 

 



ant elder <ant.elder@gmail.com> 
06/15/2009 03:31 AM
Please respond to
user@tuscany.apache.org


To
user@tuscany.apache.org
cc

Subject
Re: Example of Dojo and Tuscany on Eclipse and WebSphere (RAD)






On Sat, Jun 13, 2009 at 8:54 PM, Willis C White<whiwill@us.ibm.com> wrote:
>
> I am looking for an example of running Dojo with Tuscany on Eclipse with
> Websphere (Rational Application Developer). Can some one point me to a
> working example?
>
> If there is no example to do exactly what I need could I get some 
assistance
> getting the example below to work.
>
> I tried to convert the example at the following address to work on 
Eclipse
> with Websphere and I ran into problems.
> 
https://svn.apache.org/repos/asf/tuscany/branches/sca-java-1.x/samples/helloworld-dojo-webapp/

>
> I am not sure what the issue was but i think it had something to do with 
the
> sca-contribution.xml  and the web.xml file or possibly not having jars 
in
> the WEB-INF/lib dir (not sure which jars to put in there)
>
> RAD 7.5
> Eclipse 3.4
> Websphere 7
>
> It goes to this address
> http://localhost:9081/HelloWorld/HelloWorldJSONRPC.html
>
> and I get this error
>
> Error 500: javax.servlet.ServletException: Filter [tuscany]: Could not 
find
> required filter class -
> org.apache.tuscany.sca.host.webapp.TuscanyServletFilter.class
>
>
>
> Willis White
>
>

I've just tried the helloworld dojo sample from the Tuscany 1.5
release in WebSphere 7.0 and it worked ok for me. As with all Tuscany
webapps in WebSphere you do need to correctly configure the
classloading, so in the Admin console application configuration click
on:

"Class loading and update detection" and then set:

Class loader order: "Classes loaded with local class loader first (parent 
last)"
WAR class loader policy: "Class loader for each WAR file in application"

So you can see what jars are included in the build webapp i've
uploaded the one that worked for me to:
http://people.apache.org/~antelder/tuscany/sample-helloworld-dojo-webapp.war


   ...ant


Mime
View raw message