tuscany-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Resende <luckbr1...@gmail.com>
Subject Re: Example of Dojo and Tuscany on Eclipse and WebSphere (RAD)
Date Sun, 14 Jun 2009 14:13:03 GMT
On Sat, Jun 13, 2009 at 12:54 PM, Willis C White<whiwill@us.ibm.com> wrote:
>
> I am looking for an example of running Dojo with Tuscany on Eclipse with
> Websphere (Rational Application Developer). Can some one point me to a
> working example?
>
> If there is no example to do exactly what I need could I get some assistance
> getting the example below to work.
>
> I tried to convert the example at the following address to work on Eclipse
> with Websphere and I ran into problems.
> https://svn.apache.org/repos/asf/tuscany/branches/sca-java-1.x/samples/helloworld-dojo-webapp/


I'm not sure what do you mean by "convert the example"  to work in
eclipse. If you follow [1], it should give you the necessary steps to
get your development environment working, and [2] give you details on
how to generate the eclipse IDE artifacts (and I assume RAD is same)
and then import the project into eclipse/RAD.


[1] http://tuscany.apache.org/sca-java-development-guide.html
[2] http://tuscany.apache.org/sca-java-development-guide.html#SCAJavaDevelopmentGuide-IDE

>
> I am not sure what the issue was but i think it had something to do with the
> sca-contribution.xml  and the web.xml file or possibly not having jars in
> the WEB-INF/lib dir (not sure which jars to put in there)
>

If you just build the war (e.g mvn clean install) and then deploy it
to WebSphere, what do you get ?
Also, Are you running plain WAS ? or does it have the SCA FeP
Installed ? If you do have the FeP, please check the following blog
post [3]

[3] http://lresende.blogspot.com/2009/03/how-to-use-apache-tuscany-with.html

> RAD 7.5
> Eclipse 3.4
> Websphere 7
>
> It goes to this address
> http://localhost:9081/HelloWorld/HelloWorldJSONRPC.html
>
> and I get this error
>
> Error 500: javax.servlet.ServletException: Filter [tuscany]: Could not find
> required filter class -
> org.apache.tuscany.sca.host.webapp.TuscanyServletFilter.class
>
>
>
> Willis White
>
>

Hope this help you get further, otherwise please let us know what
other issues you are seeing.

-- 
Luciano Resende
Apache Tuscany, Apache PhotArk
http://people.apache.org/~lresende
http://lresende.blogspot.com/

Mime
View raw message