tuscany-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amita Vadhavkar" <amita.vadhav...@gmail.com>
Subject Re: [Java SDO] Tuscany SDO Java 1.1-incubating
Date Fri, 25 Jan 2008 08:38:39 GMT
I have spawned another thread
http://www.mail-archive.com/tuscany-user@ws.apache.org/msg02449.html for the
testEncoding() issue I am facing. Will you
please take a look at findings there and comment there? I will update the
final resolution for it here when we get one.

Regards,
Amita

On Jan 24, 2008 4:29 PM, Amita Vadhavkar <amita.vadhavkar@gmail.com> wrote:

> Yes, its maven build that is giving this failure, am checking more on it.
>
> Regards,
> Amita
>
>
> On Jan 24, 2008 4:25 PM, kelvin goodson <kelvin@thegoodsons.org.uk >
> wrote:
>
> > Hmmm,   I also just wiped (moved aside) my whole repo, and got a clean
> > build
> > again.  I can't think what the issue could be. I was thinking it might
> > be
> > something to do with running the tests in Eclipse,  but I am assuming
> > you
> > are not doing that because of the discussions we have had about wiping
> > the
> > maven repo; so just to be clear,  can I check that it is the maven build
> > that is giving you these errors, yes?
> > Kelvin
> >
> > On 24/01/2008, Amita Vadhavkar < amita.vadhavkar@gmail.com> wrote:
> > >
> > > Hi Kelvin,
> > > What I did was -
> > > renamed C:\Documents and Settings\Administrator\.m2\repository ->
> > > C:\Documents and Settings\Administrator\.m2\repository_bkp
> > > so that I don't have any maven repo and did a fresh svn checkout of
> > SDO
> > > Java
> > > and tried to build - with this I get testEncoding() failure.
> > >
> > > Am also seeing below in tools-tests - Failed tests:
> > >   testSimpleTypeExtension(
> > > org.apache.tuscany.sdo.test.SubstitutionWithExtensionV
> > > aluesTestCase)
> > >
> > > Tests in error:
> > >   testComplexTypeWithSimpleContentExtensionMetaData(
> > > org.apache.tuscany.sdo.test.
> > > SubstitutionWithExtensionValuesTestCase)
> > >   testComplexTypeWithSimpleContentExtensionChangeSummary(
> > > org.apache.tuscany.sdo.
> > > test.SubstitutionWithExtensionValuesTestCase )
> > >   testChangeSummaryOnDataGraphWithIntAndFloat(
> > > org.apache.tuscany.sdo.test.Change
> > > SummaryGenTestCase)
> > >
> > > Tests run: 23, Failures: 1, Errors: 3, Skipped: 0
> > >
> > >
> > > Also, is there any known reason why
> > >         suite.addTestSuite(DataObjectGetListTestCase.class);
> > >         suite.addTestSuite(ListWithDefaultTestCase.class);
> > >         suite.addTestSuite(
> > SubstitutionWithExtensionValuesTestCase.class);
> > > the above ones are not in AllTests in tools-test?
> > >
> > > I am investigating more.
> > >
> > > Regards,
> > > Amita
> > >
> > > On Jan 24, 2008 4:01 PM, kelvin goodson < kelvin@thegoodsons.org.uk>
> > wrote:
> > >
> > > > Amita,
> > > >
> > > >  do you still see this?  I wiped all eclipse artifacts from my local
> > > repo
> > > > and did a clean build.  All ran fine.  If you are still seeing it,
> > > perhaps
> > > > you can give some more detail on the errors.  Maybe you could paste
> > some
> > > > relevant error report sections from the files in
> > target/surefire-reports
> > > >
> > > > Kelvin.
> > > >
> > > > On 21/01/2008, Amita Vadhavkar <amita.vadhavkar@gmail.com> wrote:
> > > > >
> > > > > After building a fresh checkout and using initially empty maven
> > repo,
> > > > all
> > > > > except testEncoding(org.apache.tuscany.sdo.test.XMLHelperTestCase)
> > > > > failed. Is this a known issue? This is due to encoding mismatch
> > > between
> > > > > the
> > > > > one coming from org.eclipse.emf.ecore.xmi.XMLResource
> > > > > is ASCII and the expected one is UTF-8
> > > > >
> > > > > Regards,
> > > > > Amita
> > > > >
> > > > > On Jan 21, 2008 4:45 PM, kelvin goodson <
> > kelvin@thegoodsons.org.uk>
> > > > wrote:
> > > > >
> > > > > > Amita
> > > > > >
> > > > > > >
> > > > > > > So I guess I can open a JIRA and fix variable HTML_HEADER
from
> >
> > > > > > > sample-sdo/DocumentSamples to contain the above and it
will do
> > the
> > > > > > trick.
> > > > > > > Does this sound OK?
> > > > > >
> > > > > >
> > > > > >   sounds good, thanks
> > > > > >
> > > > > > Kelvin.
> > > > > >
> > > > >
> > > >
> > >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message