tuscany-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Budinsky <fra...@ca.ibm.com>
Subject Re: java.lang.ClassCastException using TypeHelper
Date Thu, 03 Aug 2006 19:10:56 GMT
Philipp,

This error is usually means that the SDO runtime has not been initialized. 
Usually it happens as a side effect of accessing SDO helpers, but 
generated classes often have this problem. We're hopefully going to come 
up with a good way to avoid this in the future, but for now you can force 
initialization by calling DataObjectUtil.initRuntime() at the very start 
of your program.

Frank.

Philipp Schöpf <philipp.schoepf@gmx.de> wrote on 08/03/2006 01:32:00 PM:

> Hi,
> 
> I am encountering strange problems with the actual tuscany build (I 
> got it from subversion this day) . This is what happens when I try 
> to determine the type of my DataObject, calling myDataObject.getType():
> 
> java.lang.ClassCastException: org.eclipse.emf.ecore.impl.EClassImpl
>  at org.apache.tuscany.sdo.impl.DataObjectImpl.
> getType(DataObjectImpl.java:190)
> 
> I tried working around this using the Typehelper on my object, but 
> this led to a similar error, calling TypeHelper.INSTANCE.
> getType(myDataObject.class);:
> 
> java.lang.ClassCastException: org.eclipse.emf.ecore.impl.EClassImpl
>  at org.apache.tuscany.sdo.helper.TypeHelperImpl.
> getType(TypeHelperImpl.java:98)
> 
> 
> Btw, my DataObject class was generated from Xsd with the 
> XSD2JavaGenerator. I am using the actual EMF 2.2.1 snapshot 
> downloaded by maven during build. Btw, I never tried the same with 
> the M1 build, should I?
> 
> Any hints?
> 
> Thanks in advance,
> Philipp
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-user-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-user-help@ws.apache.org


Mime
View raw message