tuscany-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Schöpf <philipp.scho...@gmx.de>
Subject java.lang.ClassCastException using TypeHelper
Date Thu, 03 Aug 2006 17:32:00 GMT
Hi,

I am encountering strange problems with the actual tuscany build (I got it from subversion
this day) . This is what happens when I try to determine the type of my DataObject, calling
myDataObject.getType():

java.lang.ClassCastException: org.eclipse.emf.ecore.impl.EClassImpl
 at org.apache.tuscany.sdo.impl.DataObjectImpl.getType(DataObjectImpl.java:190)

I tried working around this using the Typehelper on my object, but this led to a similar error,
calling TypeHelper.INSTANCE.getType(myDataObject.class);:

java.lang.ClassCastException: org.eclipse.emf.ecore.impl.EClassImpl
 at org.apache.tuscany.sdo.helper.TypeHelperImpl.getType(TypeHelperImpl.java:98)


Btw, my DataObject class was generated from Xsd with the XSD2JavaGenerator. I am using the
actual EMF 2.2.1 snapshot downloaded by maven during build. Btw, I never tried the same with
the M1 build, should I?

Any hints?

Thanks in advance,
Philipp


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message