tuscany-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Nash (JIRA)" <...@tuscany.apache.org>
Subject [jira] Commented: (TUSCANY-3762) Tuscany SCA Eclipse plugin doesn't install correctly
Date Tue, 02 Nov 2010 12:30:29 GMT

    [ https://issues.apache.org/jira/browse/TUSCANY-3762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12927376#action_12927376
] 

Simon Nash commented on TUSCANY-3762:
-------------------------------------

Some work has been done on a replacement update site / feature / plug-in as described in TUSCANY-2563.
 This has some refactoring improvements and is compatible with the current Eclipse software
installer.  The code for this is in the 1.x trunk under "tools/eclipse34" but it isn't in
the build and has never been released, and it's not clear what state it's in.

For 1.6.1 I think it's too much work and too risky to try to get the "tools/eclipse34" version
working and tested and switch over to using it.  Instead I have made some changes to the current
"tools/eclipse" version of the feature and plug-in that resolve the specific problems described
in this JIRA.

For a future release we should re-evaluate whether to continue with "tools/eclipse" or change
to using "tools/eclipse34".

> Tuscany SCA Eclipse plugin doesn't install correctly
> ----------------------------------------------------
>
>                 Key: TUSCANY-3762
>                 URL: https://issues.apache.org/jira/browse/TUSCANY-3762
>             Project: Tuscany
>          Issue Type: Bug
>          Components: Java SCA Tools
>    Affects Versions: Java-SCA-1.6
>            Reporter: Simon Nash
>            Assignee: Simon Nash
>             Fix For: Java-SCA-1.6.1
>
>
> When installing the Tuscany SCA Eclipse feature and plugin from the Eclipse update site,
there are a number of problems as follows:
> 1. The Tuscany SCA Eclipse feature installation isn't compatible with the current Eclipse
software installation and update mechanism in Eclipse 3.4 and above. This forces a switch
to the older Update Manager which requires the update site information to be re-entered.
> 2. After the installation completes, the Eclipse installed software window doesn't have
an entry for Tuscany in the Installed Software or Features tabs. Tuscany is shown only in
the Plug-ins tab.
> 3. It isn't possible to uninstall the Tuscany SCA Eclipse feature.  The Tuscany feature
and plugin directories can be deleted from Eclipse manually but this doesn't remove the Tuscany
plug-in from the list of installed plug-ins.
> 4. The version number of the Tuscany SCA Eclipse feature and plug-in doesn't conform
to Eclipse format conventions which require a timestamp following the release number.
> 5. It's not possible to install and test the Tuscany SCA Eclipse feature when it's built
from the trunk or from a release branch because Eclipse can't handle n.n.n-SNAPSHOT as a version
number.
> 6. The Tuscany SCA Eclipse feature and plug-in don't conform to Eclipse conventions for
displaying copyright and license information when they are installed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message