tuscany-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eborn, Eric D" <eric.d.eb...@lmco.com>
Subject Help with Customers tuscany demo
Date Tue, 04 Sep 2007 13:47:21 GMT
I've run the demo using Derby, however, I've been unsuccessful in doing
so with MySQL.

 

I'm running the latest mysql and connector/J, downloaded them this week.
Please advise.

 

When I comment out the Derby config and uncomment the MySql config, I
get the following error:

 

BUILD SUCCESSFUL

Total time: 0 seconds

D:\data\eeborn\Desktop\TUSCAN~1.0-I\samples\customer>ant

Buildfile: build.xml

 

run:

     [java] Exception in thread "main" java.lang.RuntimeException:
org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Feature
'user' not foun

d. (http:///temp.xml, 50, 33)

     [java]     at
org.apache.tuscany.das.rdb.util.ConfigUtil.loadConfig(ConfigUtil.java:54
)

     [java]     at
org.apache.tuscany.samples.das.customer.CustomerClient.main(CustomerClie
nt.java:86)

     [java] Caused by:
org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Feature
'user' not found. (http:///temp.xml, 50, 33)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.handleErrors(XMLLoadImpl.java
:80)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:275)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.ja
va:666)

     [java]     at
org.apache.tuscany.sdo.util.resource.SDOXMLResourceImpl.doLoad(SDOXMLRes
ourceImpl.java:465)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.load(XMLResourceImpl.java
:634)

     [java]     at
org.apache.tuscany.sdo.helper.XMLDocumentImpl.load(XMLDocumentImpl.java:
239)

     [java]     at
org.apache.tuscany.sdo.helper.XMLDocumentImpl.load(XMLDocumentImpl.java:
217)

     [java]     at
org.apache.tuscany.sdo.helper.XMLHelperImpl.load(XMLHelperImpl.java:78)

     [java]     at
org.apache.tuscany.sdo.helper.XMLHelperImpl.load(XMLHelperImpl.java:72)

     [java]     at
org.apache.tuscany.das.rdb.util.ConfigUtil.loadConfig(ConfigUtil.java:52
)

     [java]     ... 1 more

     [java] Caused by:
org.eclipse.emf.ecore.xmi.FeatureNotFoundException: Feature 'user' not
found. (http:///temp.xml, 50, 33)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.reportUnknownFeature(XMLHandle
r.java:1744)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleUnknownFeature(XMLHandle
r.java:1708)

     [java]     at
org.apache.tuscany.sdo.util.resource.SDOXMLResourceImpl$SDOXMLLoadImpl$X
mlHandler.handleUnknownFeature(SDOXMLResourceImpl.java:255)

 

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.setAttribValue(XMLHandler.java
:2463)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.SAXXMLHandler.handleObjectAttribs(SAXXMLH
andler.java:72)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObject(XMLHandler.java:1
988)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObjectFromFeatureType(XM
LHandler.java:1896)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObject(XMLHandler.java:1
788)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleFeature(XMLHandler.java:
1566)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.processElement(XMLHandler.java
:884)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:8
63)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:6
27)

     [java]     at
org.apache.tuscany.sdo.util.resource.SDOXMLResourceImpl$SDOXMLLoadImpl$X
mlHandler.startElement(SDOXMLResourceImpl.java:289)

     [java]     at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElemen
t(AbstractSAXParser.java:501)

     [java]     at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanSta
rtElement(XMLNSDocumentScannerImpl.java:400)

     [java]     at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$F
ragmentContentDriver.next(XMLDocumentFragmentScannerImpl.ja

va:2740)

     [java]     at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLD
ocumentScannerImpl.java:645)

     [java]     at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XM
LNSDocumentScannerImpl.java:140)

     [java]     at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.s
canDocument(XMLDocumentFragmentScannerImpl.java:508)

     [java]     at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML1
1Configuration.java:807)

     [java]     at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML1
1Configuration.java:737)

     [java]     at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.jav
a:107)

     [java]     at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Abstr
actSAXParser.java:1205)

     [java]     at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.pars
e(SAXParserImpl.java:522)

     [java]     at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)

     [java]     at
org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:265)

     [java]     ... 9 more

     [java] Java Result: 1

 

 

 

 

I have this config Customers.xml

 

            <!--Uncomment below for MySQL test-->

                        <ConnectionInfo>

                                    <ConnectionProperties

                                    driverClass="com.mysql.jdbc.Driver"

 
databaseURL="jdbc:mysql://localhost:3306/test"

                                user="root"

                                password="foobar"

                                loginTimeout="600000">

                            </ConnectionProperties>

                        </ConnectionInfo>

 

 

                        <!-- ConnectionInfo
dataSource="java:comp/env/jdbc/dastest"    THIS SECTION IS COMMENTED OUT

 
contextAvailable="false">

                        <ConnectionProperties 

 
dataSourceClass="com.mysql.jdbc.jdbc2.optional.MysqlDataSource"

                                    user="root"

                                    password="foobar"

                                    key="193-155-248-97-234-56-100-241"

                                    databaseName="test"

                                    loginTimeout="600000">

                        </ConnectionProperties>

                        </ConnectionInfo -->

 

 

 

The section of the config that is commented out also fails with: 

run:

     [java] Exception in thread "main" java.lang.RuntimeException:
org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Feature
'contextAvailab

le' not found. (http:///temp.xml, 55, 30)

     [java]     at
org.apache.tuscany.das.rdb.util.ConfigUtil.loadConfig(ConfigUtil.java:54
)

     [java]     at
org.apache.tuscany.samples.das.customer.CustomerClient.main(CustomerClie
nt.java:86)


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message