turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dant...@yorku.ca>
Subject RE: troubles migrating to turbine 2.3
Date Wed, 04 Aug 2004 16:31:35 GMT

Hi Mark,

That's correct, there is a problem with working with images...see the
message thread with subject "actionevent" which was actually just a week
or two ago.

Regards,
Daniel

On Wed, 4 Aug 2004, Mark Lybarger wrote:

> According to the folks on our group that looked heavily into the issue, it seems that
it is limited to image buttons.  I think the issue has something to do with the .X and or
.Y that gets appended to the name when being submitted.  Possibly a w3c thing.  We have a
work around for now, but will probably be looking into getting at a more recent copy of turbine
2.3.
>
> It would be really nice if there were an "official" binary release of turbine 2.3.1 which
contains bug fixes and such since we have such a challenge building turbine.  I'll try to
bild the 2.3.1-dev when i have a chance and see how it goes.
>
> Thanks!
> ~mark
>
> > -----Original Message-----
> > From: Peter Courcoux [mailto:peter@courcoux.biz]
> > Sent: Tuesday, August 03, 2004 4:24 PM
> > To: Turbine Users List
> > Subject: RE: troubles migrating to turbine 2.3
> >
> >
> > Mark,
> >
> > Can you try a non image button submit and see if this works.
> >
> > Peter
> >
> >
> >
> > On Tue, 2004-08-03 at 19:44, Mark Lybarger wrote:
> > > > -----Original Message-----
> > > > From: Daniel [mailto:dantest@yorku.ca]
> > > > Sent: Tuesday, August 03, 2004 1:06 PM
> > > > To: Turbine Users List
> > > > Subject: Re: troubles migrating to turbine 2.3
> > > >
> > > >
> > > >
> > > > On Tue, 3 Aug 2004, Mark Lybarger wrote:
> > > >
> > > > > hi,
> > > > >
> > > > > we seem to be hitting a few road blocks migrating to
> > > > turbine 2.3 (we're going from a slightly modified turbine
> > > > 2.1). we're using the jakarta-turbine-2.3.tar.gz from the
> > > > apache mirrors.
> > > > >
> > > > > the first issue seems to be with the torque maven plugin
> > > > and with maven in general.  we're not very schooled on maven
> > > > much, and have had one heck of a time getting the turbine
> > > > source tree to build with it.  we're behind a firewall and
> > > > can't easily get out (http proxy is avail).  we've only
> > > > really had one person on our group to get turbine to build,
> > > > and then we just took that exact maven folder and maven
> > > > repository to others machines to build.  could someone tell
> > > > me the specific environment (maven version, etc) that works
> > > > nicely with turbine? do other experience maven difficulties
> > > > building turbine?
> > > >
> > > > Sorry, don't use torque here so can't offer any advice on it..
> > > >
> > > > > next, we have encountered an issue with turbine's handling
> > > > of our actions method to call. for instance, on a form we
> > > > have an input button called: name="eventSubmit_doInsert"
> > on a form of:
> > > > > <form name="fee_action_form" method="POST"
> > > > action="$link.setAction( "feemaint.FeeAction" )">
> > > > >
> > > > > with turbine 2.1, this turbine would run the doInsert()
> > > > method of the FeeAction class.  With turbine 2.3, we could
> > > > only get the doPerform method of that class to run.  someone
> > > > in our group mentioned that this was fixed after the 2.3
> > > > release of turbine and that if we could get the latest from
> > > > the 2.3 branch, we'd have the fix.  has anyone else noticed
> > > > this behavior with the released turbine 2.3?  and how active
> > > > is the maintenance on 2.3?  do most people run from the
> > > > lastest cvs version of the turbine they're using?  we don't
> > > > have good access to an external cvs server (turbine's), and
> > > > the only thing i see for the nightlies are 2.3.1-dev
> > > > versions, or patches for turbine 2.3 which seem to predate
> > > > the 2.3 release.
> > > >
> > > > This should definitely work.  I've migrated two Turbine 2.1
> > > > apps without
> > > > changing any actions and their methods.  I would compare
> > the request
> > > > parameters for each instance and see if they are differrent.
> > > > The method
> > > > doPerform() is the default method that gets called if there's
> > > > no specified
> > > > event.  Also ensure your input button is of type "submit".
> > >
> > > our "buttons" are images. should this not work with tr 2.3?
> > >
> > > <INPUT type="image" border="0" src="$content.getURI(
> > "images/add.gif" )" alt="Submit" align="absbottom"
> > name="eventSubmit_doInsert">
> > >
> > > >
> > > > And, so far I've yet to experience problems with the binary
> > > > release of the
> > > > turbine 2.3, though the version in CVS is probably "better".
> > > >
> > > > Regards,
> > > > Daniel
> > > >
> > > >
> > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail:
> > turbine-user-unsubscribe@jakarta.apache.org
> > > > For additional commands, e-mail:
> > turbine-user-help@jakarta.apache.org
> > > >
> > > >
> > > >
> > >
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> > > For additional commands, e-mail:
> > turbine-user-help@jakarta.apache.org
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: turbine-user-help@jakarta.apache.org
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: turbine-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-user-help@jakarta.apache.org


Mime
View raw message