turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Lybarger" <Mark.Lybar...@CBC-Companies.com>
Subject RE: strange intake issue - tdk 2.2 wls 8.1.2
Date Mon, 16 Aug 2004 15:08:05 GMT
ok, it took a few minutes playing around with it, but it seems that changing the TR.props from

services.IntakeService.xml.path=WEB-INF/conf/intake.xml
to
services.IntakeService.xml.path=/WEB-INF/conf/intake.xml
resolved my issue.

thanks!

> -----Original Message-----
> From: Mark Lybarger 
> Sent: Monday, August 16, 2004 10:59 AM
> To: Turbine Users List
> Subject: RE: strange intake issue - tdk 2.2 wls 8.1.2
> 
> 
> I've dug into my turbine.log file and found the below error.  
> Somehow there is a . that is getting put into the path for 
> the intake.xml file.  my tr.props has: 
> 
> services.IntakeService.xml.path=WEB-INF/conf/intake.xml
> 
> i'm not quite sure how to work around this or fix it...
> 
> 
> [Mon Aug 16 10:49:18 EDT 2004] -- ERROR -- 
> 	Exception:  
> org.apache.turbine.services.InitializationException: 
> TurbineIntakeService failed to initialize: 
> /usr/local/bea/weblogic81/user_projects/domains/score-dev/appl
> ications/scoring./WEB-INF/conf/intake.xml (No such file or directory)
> 	Stack Trace follows:
> 	java.io.FileNotFoundException: 
> /usr/local/bea/weblogic81/user_projects/domains/score-dev/appl
> ications/scoring./WEB-INF/conf/intake.xml (No such file or directory)
> 	at java.io.FileInputStream.open(Native Method)
> 	at java.io.FileInputStream.<init>(FileInputStream.java:103)
> 	at java.io.FileInputStream.<init>(FileInputStream.java:66)
> 	at java.io.FileReader.<init>(FileReader.java:41)
> 	at 
> org.apache.turbine.services.intake.transform.XmlToAppData.pars
> eFile(XmlToAppData.java:126)
> 	at 
> org.apache.turbine.services.intake.transform.XmlToAppData.pars
> eFile(XmlToAppData.java:101)
> 	at 
> org.apache.turbine.services.intake.TurbineIntakeService.writeA
> ppData(TurbineIntakeService.java:235)
> 	at 
> org.apache.turbine.services.intake.TurbineIntakeService.init(T
> urbineIntakeService.java:184)
> rethrown as 
> org.apache.turbine.services.InitializationException: 
> TurbineIntakeService failed to initialize: 
> /usr/local/bea/weblogic81/user_projects/domains/score-dev/appl
> ications/scoring./WEB-INF/conf/intake.xml (No such file or directory)
> 	at 
> org.apache.turbine.services.intake.TurbineIntakeService.init(T
> urbineIntakeService.java:221)
> 	at 
> org.apache.turbine.services.TurbineBaseService.init(TurbineBas
> eService.java:108)
> 	at 
> org.apache.turbine.services.BaseInitableBroker.initClass(BaseI
> nitableBroker.java:149)
> 	at 
> org.apache.turbine.services.BaseServiceBroker.doInitService(Ba
> seServiceBroker.java:224)
> 	at 
> org.apache.turbine.services.BaseServiceBroker.initServices(Bas
> eServiceBroker.java:193)
> 	at org.apache.turbine.Turbine.init(Turbine.java:257)
> 	at javax.servlet.GenericServlet.init(GenericServlet.java:258)
> 	at 
> weblogic.servlet.internal.ServletStubImpl$ServletInitAction.ru
> n(ServletStubImpl.java:993)
> 	at 
> weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authe
> nticatedSubject.java:317)
> 	at 
> weblogic.security.service.SecurityManager.runAs(SecurityManage
> r.java:118)
> 	at 
> weblogic.servlet.internal.ServletStubImpl.createServlet(Servle
> tStubImpl.java:869)
> 	at 
> weblogic.servlet.internal.ServletStubImpl.createInstances(Serv
> letStubImpl.java:848)
> 	at 
> weblogic.servlet.internal.ServletStubImpl.prepareServlet(Servl
> etStubImpl.java:787)
> 	at 
> weblogic.servlet.internal.WebAppServletContext.preloadServlet(
> WebAppServletContext.java:3252)
> 	at 
> weblogic.servlet.internal.WebAppServletContext.preloadServlets
> (WebAppServletContext.java:3197)
> 	at 
> weblogic.servlet.internal.WebAppServletContext.preloadResource
> s(WebAppServletContext.java:3174)
> 	at 
> weblogic.servlet.internal.WebAppServletContext.setStarted(WebA
> ppServletContext.java:5647)
> 	at 
> weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:869)
> 	at 
> weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationCo
> ntainer.java:2022)
> 	at 
> weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicatio
> nContainer.java:2063)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$ComponentActiva
> teTask.activateContainer(SlaveDeployer.java:2592)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.do
> Commit(SlaveDeployer.java:2515)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$Task.commit(Sla
> veDeployer.java:2317)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$Task.checkAutoC
> ommit(SlaveDeployer.java:2399)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$Task.prepare(Sl
> aveDeployer.java:2311)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.pr
> epare(SlaveDeployer.java:2479)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer.processPrepareT
> ask(SlaveDeployer.java:798)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(Sl
> aveDeployer.java:507)
> 	at 
> weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(S
> laveDeployer.java:465)
> 	at 
> weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCall
> backHandler.java:25)
> 	at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197)
> 	at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
> 
> > -----Original Message-----
> > From: Daniel [mailto:dantest@yorku.ca]
> > Sent: Monday, August 16, 2004 10:40 AM
> > To: Turbine Users List
> > Subject: Re: strange intake issue - tdk 2.2 wls 8.1.2
> > 
> > 
> > 
> > Hi Mark,
> > 
> > Perhaps it's a directory permission problem... The 
> > appData.ser file must
> > be creatable.
> > 
> > Regards,
> > Daniel
> > 
> > On Mon, 16 Aug 2004, Mark Lybarger wrote:
> > 
> > > i'm having a very strange intake issue.  i have a web 
> > application built under the tdk 2.2 which is deployed under 
> > wls 8.1.  the app starts up fine on my win 2k machine, and 
> > intake changes are recognized, etc.  all is good until i 
> > migrate the app to a solaris machine.  there, intake refuses 
> > to startup and i see $intake.declareGroups() on my rendered 
> > templates.  if i manually send the appData.ser from my win 2k 
> > box to the solaris box, then intake starts fine.  i've tried 
> > doing a dos2unix on the intake.xml file but that didn't seem 
> > to help at all.  i can't find anything at all that would 
> > point to why intake doesn't like to startup on this solaris 
> > instance.  any insights would be extremely appreciated.  wls 
> > 8.1.2 is using sun jdk 1.4.1_05, and the same jdk version is 
> > being used on both machines.
> > >
> > > thanks!
> > > ~mark
> > >
> > >
> > >
> > > 
> > 
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: 
> turbine-user-unsubscribe@jakarta.apache.org
> > > For additional commands, e-mail: 
> > turbine-user-help@jakarta.apache.org
> > >
> > >
> > 
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: 
> turbine-user-help@jakarta.apache.org
> > 
> > 
> > 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: turbine-user-help@jakarta.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-user-help@jakarta.apache.org


Mime
View raw message