turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Kuncikowski <kuncikow...@evamann.de>
Subject Re: maven turbine:deploy prob
Date Tue, 31 Aug 2004 08:53:07 GMT
i tested this on a mac os x box,
same configuration, same ide settings, etc
(testing with the removed code snippet!)

result:
under *nix it doesn't work with ${pom.build.SourceDirectory} pointing
to the basedir of the app! which is needed under win.
there it only works correctly when it points to the java src dir (src/java)!?!
and only the changed source files will be compiled as wished.

i'm interested if i'm the only one with this problem.

thx for listening,
greetz
sven kuncikowski


Sven Kuncikowski wrote:
> ok, i've found it myself,
> but it confuses me -> so this goes primarily to the developer(s):
> 
> i traced down why my app is copied twice into the webapps dir.
> in the maven-turbine-plugin-1.2-dev jelly.properties the attainGoal jar:jar
> contains the following:
> [code snippet]
>    <copy todir="${turbine.target.dir}/WEB-INF/classes" filtering="no">
>    <fileset dir="${pom.build.SourceDirectory}">
>        <exclude name="**/*java"/>
>       </fileset>
>     </copy>
> [/code snippet]
> 
> 
> with the above setting, everything (the whole project) will be copied 
> into the app/WEB-INF/classes directory,
> due to the setting of ${pom.build.SourceDirectory}.
> 
> or is there a reason why the whole project should be copied to the 
> app/WEB-INF/classes directory?
> 
> shouldn't the above code snippet be removed?
> without it, everything is copied only once and works fine.
> the m.e.t.a plugin is from the jakarta-turbine-2-branch 2.3 tree.
> 
> i think that i haven't had the problem as i was using the 
> jakarta-turbine head m.e.t.a plugin.
> 
> greetz,
> sven kuncikowski
> 
> 
> 
> 
> 
> 
> 
> 
> Sven Kuncikowski wrote:
> 
>> hi everybody,
>>
>> i cannot figure out why maven turbine:deploy
>> copies my whole project dir into the
>>
>> D:\tomcat\webapps\movii\WEB-INF\classes
>>
>> folder?!?
>>
>> first it copies the compiled classes (which is correct)
>> and then it copies my whole project into the classes folder.
>>
>> this behavior wasn't always there,
>> but i'm not quiete sure when it appears,
>> i think it was after i switched to the turbine-2.3-branch
>>
>> when i create a war archiv the error doesn't occur.
>>
>> another prob is that two fellow developer checked  out the project
>> and everytime maven is called maven copies the src folder into
>> the basedir of the project!
>> i have not that prob, which is very confusing to me,
>> though everybody has the same .properties files.
>>
>> thx for any help!
>> greetz,
>> sven kuncikowski
>>
>>
>>
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: turbine-user-help@jakarta.apache.org
> 
> 
> 
> ------------------------------------------------------------------------
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: turbine-user-help@jakarta.apache.org


Mime
View raw message