turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "EXT-McTaggart, Peter" <peter.mctagg...@boeing.com>
Subject Oracle , Blobs and Village
Date Thu, 15 Jan 2004 04:49:18 GMT
Hi,

I've seen these issues talked about on the list but I wasn't able to
work out what is the
current state of play, and what is the best option to fix this (if at
all possible).

Here is the issue,

I have a few tables that need large test fields in my database. I
originally developed it on
MySQL and it worked very well using the MEDIUM TEXT field. I need to
convert the database
to Oracle 9i and VARCHAR2(4000) is too small so I converted these fields
to BLOBs.

I can create the schema and have overriden the getters and setters in
the OM class to accept and
dish up the blobs as strings which all seems to work.
But I am now getting a Null Pointer Exception in Village when I try to
retreive the results of a doSelect().
The SQL works fine but Village bombs our inside the constructor for the
Value objects.

Here is the stack trace:
[WARN] ViewActions - -Exception during get user tasks:
org.apache.torque.TorqueE
xception
java.lang.NullPointerException
        at com.workingdogs.village.Value.<init>(Unknown Source)
        at com.workingdogs.village.Record.createValues(Unknown Source)
        at com.workingdogs.village.Record.<init>(Unknown Source)
        at com.workingdogs.village.DataSet.fetchRecords(Unknown Source)
        at com.workingdogs.village.DataSet.fetchRecords(Unknown Source)
        at com.workingdogs.village.DataSet.fetchRecords(Unknown Source)
        at
org.apache.torque.util.BasePeer.getSelectResults(BasePeer.java:1657)
        at
org.apache.torque.util.BasePeer.executeQuery(BasePeer.java:1545)
        at org.apache.torque.util.BasePeer.doSelect(BasePeer.java:1391)
        at org.apache.torque.util.BasePeer.doSelect(BasePeer.java:1368)
        at
com.mycompany.BaseDeadlinePeer.doSelectVillageRecords(BaseDeadlinePeer.j
ava:388)

I'm using TDK 2.3.
This includes a Village-2.0-dev.jar file -- I can only see 1.5.3 at
http://share.whichever.com/index.php?SCREEN=village Is there some other
place that
I can find the source code for this?

Can anyone give me some pointers as to the best approach to fix this, I
seem to recall a message that said you needed to 
modify the Village code and rebuild it but I can't seem to find it
again.

Thanks for your help,

cheers
peter




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message