turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Pugh" <ep...@upstate.com>
Subject RE: Building Fulcrum - does it work for anyone?
Date Fri, 16 Jan 2004 19:01:40 GMT
Okay..   Maven is great, but can also be a pain in that now people are
starting to extend maven, but the ability to download and install plugins
hasn't been fully baked in yet.  The problem you are running into is that
you don't have the avalon meta plugin installed.  Go to
http://www.ibiblio.org/maven/avalon-meta/plugins/ and grab the latest
(1.3.2) version and put the jar in your maven/plugins/ directory and then
try the build...

If you have build maven post RC1, then you can do:
maven
plugin:download -DartifactId=avalon-meta-plugin -DgroupId=avalon-meta -Dvers
ion=1.3.2
and it will install...

I will update the startup directions!

Eric

> -----Original Message-----
> From: Gerry Duprey [mailto:gduprey@Schools-OPEN.com]
> Sent: Friday, January 16, 2004 7:47 PM
> To: Turbine Users List
> Subject: Building Fulcrum - does it work for anyone?
>
>
> Howdy All,
>
> I'm trying to build Fulcrum (well, I'm trying to use Turbine
> and then trying
> to integrate Hibernate, and then trying to use hibernate for
> security in
> turbine, etc, etc) so I can use the Hibernate security
> services that have been
> committed.
>
> I have the latest maven installed (RC1) and it seems happy enough.
>
> I used CVS to grab a copy of Fulcrum.  Then I followed the
> instructions on the
> Fulcrum web site for building it
> (http://jakarta.apache.org/turbine/fulcrum/building.html --
> rename src and add
> the -Dmaven.test.skip=true).  If I issue just the maven command
>
> maven -Dmaven.test.skip=true
>
> then it goes for a bit and when building the Configuration
> Impl complains:
>
>
> BUILD FAILED
> File......
> file:/usr/local/dev/jakarta/fulcrum/jakarta-turbine-fulcrum/
> Element... maven:reactor
> Line...... 15
> Column.... 32
> Unable to obtain goal [java:compile] --
> file:/usr/local/dev/jakarta/fulcrum/jakarta-turbine-fulcrum/co
nfiguration/impl/:4:37:
<attainGoal> No goal [avalon:meta]

I really don't know much about Maven.  I've tried to read everything I can
and
other than other folks having problems, nothing seems relavant (or is a year
or two old).  I've tried the multisite:project mentioned in the web page and
maven complains that doesn't exist in the project.  I've tried jar and
jar:jar
(I have no idea of the diff between the two are, but I've seen both
mentioned,
just trying anything I can) and with jar it quickly does a bunch of steps
but
doesn't seem to actually compile anything (nothing in target/classes).

Any help on how to build this would be appreciated.  I know folks are
working
on all this and I'm doing my best to keep a stiff upper lip over the
problems,
but I just can't seem to get anything to work (along the general lines of
trying to get hibernate and security to work in turbine).  A few pointers
would be really helpful.

Thanks

Gerry

--
Gerry Duprey
________________________________________
SchoolsOPEN, LLC
123 North Ashley, Suite 120
Ann Arbor, MI 48104
Phone (877) 483-1944 Ext. 401
Fax (734) 661-0819

Visit us Online at www.Schools-OPEN.com


---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-user-help@jakarta.apache.org


Mime
View raw message