turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Pugh" <ep...@upstate.com>
Subject RE: Which modules work with Turbine 2.3
Date Tue, 20 Jan 2004 08:38:18 GMT
It depends (of course!)...

Turbine 2.3 was based around decoupling Torque and adding the
AvalonComponentService.  As part of this, many "services" where spun off
into Fulcrum.  The criteria was that is a "service" was generally useful
outside of Turbine, then put it in Fulcrum.  If a service (like RunData) was
Turbine specific, then keep it in Turbine.  However, part of the rules of
deprecatation are that until Turbine 2.4 is released, the code moved from
Turbine to Fulcrum can not be deleted from the Turbine 2.3 repo.  Indeed,
Turbine 2.3 uses the old versions.

However, if you look at the code in CVS head that will be released as 2.4.
And in 2.4 we are using various components from Fulcrum.   Look at the
project.xml[1] to see the fulcrum jars.

Now, if you are using Turbine 2.3 and want to roll in the Fulcrum Security
stuff, then in that case you want to look at the config files in the unit
test for the 2.3 Turbine -> Security Adapter [2].  This shows how you
include the components in Turbine 2.3 [3] as well as all the config data you
can delete from a default 2.3 TurbineResources.properties file.

Eric Pugh



[1] http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-2/project.xml
[2]
http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-fulcrum/security/adapters/
turbine/src/test/AdapterTestTurbineResources.properties
[3]
http://cvs.apache.org/viewcvs.cgi/jakarta-turbine-fulcrum/security/adapters/
turbine/src/test/

> -----Original Message-----
> From: Gerry Duprey [mailto:gduprey@Schools-OPEN.com]
> Sent: Monday, January 19, 2004 6:21 PM
> To: turbine-user@jakarta.apache.org
> Subject: Which modules work with Turbine 2.3
>
>
> Howdy,
>
> Now that building furlcrumis working well, a few questions
> about the services
> Fulcrum provides and Turbine 2.3
>
> In particular, which services can I use with Turbine 2.3 in a
> "replacement of
> Turbine functionality" means (i.e. override a supplied service)?
>
> Also, there are a lot of Fulcrum jars - can I just pick the
> ones I want to use
> with Turbine or are there some "mandatories" in there?
>
> Thanks!
>
> Gerry
> --
> Gerry Duprey
> ________________________________________
> SchoolsOPEN, LLC
> 123 North Ashley, Suite 120
> Ann Arbor, MI 48104
> Phone (877) 483-1944 Ext. 401
> Fax (734) 661-0819
>
> Visit us Online at www.Schools-OPEN.com
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: turbine-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: turbine-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: turbine-user-help@jakarta.apache.org


Mime
View raw message