turbine-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Campbell <christopher.campb...@campbellvision.com>
Subject Re: [Relatively Newbie] NoClassDefFoundError when trying to logon
Date Sat, 01 Dec 2001 09:15:13 GMT
OOPS ....

After wasting a lot of time I decided to followup the hunch I originally 
had that
it had something to do with mysql. Umm ... took a look in the mysql 
config file
my.cnf and noticed that network access was switched off. I could connect 
to the
database with the mysql client which did so via the socket file and not 
via a network
socket.

So if anyone ever gets such an exception ... try checking your (mysql) 
database
configuration.

Christopher


Christopher Campbell wrote:

> It seems that this is a problem caused by the debain disribution I am 
> running.
> However, I haven't found out whats the problem.
> If anyone has had a similar problem, your input would be much 
> appreciated.
>
> Chris
>
> Christopher Campbell wrote:
>
>> Hi everyone,
>>
>> this is my second posting, so I'm quite new.
>>
>> I've written a wee application and everything works fine at home:
>>
>> Linux SuSe7.2
>> JDK1.3
>> MYSQL
>> TDK2.1 with CVS turbine2.2b1.jar
>>
>> I then packaged the webapp dir (tarred & gzipped things and dumped 
>> the MYSQL turbine database),
>> transferred the whole thing to a different box:
>> Debian
>> JDK1.3
>> MYSQL
>> TOMCAT4.0.1
>>
>> I just gunzipped/untarred things into the TOMCAT webapps dir,
>> loaded the turbine database dump onto the new MYSQL server,
>> started tomcat and tried to logon, however I constantly get two errors:
>> Initially, directly after starting tomcat I get the error:
>>
>> Turbine.handleException:
>> Error in BasePeer.initTableSchema(TURBINE_USER):
>> Cannot connect to MySQL server on 127.0.0.1:3306.
>> Is there a MySQL server running on the machine/port you are trying to 
>> connect to? (java.net.ConnectException)
>>
>> Note: MYSQL is setup correctly to allow access from 127.0.0.1/localhost.
>>
>> Then on successive attempts to login I get:
>>
>> [Wed Nov 28 22:07:47 CET 2001] -- ERROR --
>>        Exception:  java.lang.NoClassDefFoundError: 
>> org/apache/turbine/om/security/peer/TurbineUserPeer
>>        Stack Trace follows:
>>        java.lang.NoClassDefFoundError: 
>> org/apache/turbine/om/security/peer/TurbineUserPeer
>>        at 
>> org.apache.turbine.services.security.db.DBUserManager.retrieve(DBUserManager.java:158)

>>
>>
>>
>> I'm assuming that it should be possible to deploy a webapp in the 
>> manner I've described
>> above.
>>
>> I would very much appreciate any help here.
>>
>> Thanks in advance.
>>
>> Chris
>>
>>
>>
>>
>>
>> -- 
>> To unsubscribe, e-mail:   
>> <mailto:turbine-user-unsubscribe@jakarta.apache.org>
>> For additional commands, e-mail: 
>> <mailto:turbine-user-help@jakarta.apache.org>
>>
>>
>>
>
>
>
> -- 
> To unsubscribe, e-mail:   
> <mailto:turbine-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:turbine-user-help@jakarta.apache.org>
>
>
>



--
To unsubscribe, e-mail:   <mailto:turbine-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:turbine-user-help@jakarta.apache.org>


Mime
View raw message